Online install stuck on `dkms install --no-depmod nvidia/550.54.14 -k 6.7.9-arch1-1`

Hi, I’m new to Arch linux, so if there’s more info you need, please ask and I will do my best to provide. But here’s some basic info:

The How to include system logs in your post page says to use inxi -Fxxc0z to include my hardware info, but the command just runs continuously without any output, so here’s the basics:
CPU: intel i5 13600k
GPU: Nvidia 4080 Super

Installer log:

I tried offline install before this, and it was also stuck on the exact same part when I tried to update the system post install.

Hardware should not be an issue in General for you, and installer log is already including hardware info too.

I only see:

  Info: 14-core (6-mt/8-st) model: 13th Gen Intel Core i5-13600K bits: 64 type: MST AMCP cache:
    L2: 20 MiB
  Speed (MHz): avg: 815 min/max: 800/5500:3900 cores: 1: 800 2: 800 3: 1100 4: 800 5: 800 6: 800
    7: 800 8: 800 9: 800 10: 800 11: 800 12: 800 13: 800 14: 800 15: 800 16: 800 17: 800 18: 800
    19: 800 20: 800
  System RAM: total: 64 GiB note: est. available: 62.59 GiB used: 2.32 GiB (3.7%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges required.
  Device-1: Intel Raptor Lake-S GT1 [UHD Graphics 770] vendor: Micro-Star MSI driver: i915
    v: kernel arch: Gen-13 process: Intel 7 (10nm) built: 2022+ ports: active: none empty: DP-1,
    DP-2, HDMI-A-1, HDMI-A-2, HDMI-A-3, HDMI-A-4 bus-ID: 00:02.0 chip-ID: 8086:a780 class-ID: 0380
  Device-2: NVIDIA vendor: Shenzhen Colorful Yugong and Development driver: nvidia v: 545.29.06
    alternate: nouveau,nvidia_drm non-free: N/A status: unknown device ID pcie: gen: 1
    speed: 2.5 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s ports: active: none
    off: DP-4,DP-5,HDMI-A-5 empty: DP-3 bus-ID: 01:00.0 chip-ID: 10de:2702 class-ID: 0300
  Display: server: X.Org v: 21.1.11 compositor: kwin_x11 driver: X: loaded: modesetting,nvidia
    alternate: fbdev,intel,nouveau,nv,vesa dri: iris gpu: nvidia,nvidia-nvswitch display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 6400x1440 s-dpi: 107 s-size: 1520x342mm (59.84x13.46")
    s-diag: 1558mm (61.34")
  Monitor-1: not-matched mapped: DP-2 pos: right res: 1920x1080 hz: 60 dpi: 82
    size: 598x336mm (23.54x13.23") diag: 686mm (27.01") modes: N/A
  Monitor-2: DP-5 mapped: DP-4 note: disabled pos: primary,left model: VG27AQ1A serial: <filter>
    built: 2022 res: 2560x1440 hz: 60 dpi: 109 gamma: 1.2 size: 597x336mm (23.5x13.23")
    diag: 685mm (27") ratio: 16:9 modes: max: 2560x1440 min: 640x480
  Monitor-3: not-matched mapped: HDMI-0 pos: center res: 1920x1080 hz: 60 dpi: 93
    size: 527x296mm (20.75x11.65") diag: 604mm (23.8") modes: N/A
  API: EGL v: 1.5 hw: drv: intel iris drv: nvidia platforms: device: 0 drv: nvidia device: 1
    drv: iris device: 3 drv: swrast gbm: drv: iris surfaceless: drv: nvidia x11: drv: nvidia
    inactive: wayland,device-2
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 545.29.06 glx-v: 1.4
    direct-render: yes renderer: NVIDIA Graphics Device/PCIe/SSE2 memory: 15.62 GiB
  API: Vulkan v: 1.3.274 layers: 1 device: 0 type: discrete-gpu name: NVIDIA Graphics Device
    driver: nvidia v: 545.29.06 device-ID: 10de:2702 surfaces: xcb,xlib
  Device-1: Realtek RTL8125 2.5GbE vendor: Micro-Star MSI driver: r8169 v: kernel pcie: gen: 2
    speed: 5 GT/s lanes: 1 port: 4000 bus-ID: 04:00.0 chip-ID: 10ec:8125 class-ID: 0200
  IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter>

non-free: N/A status: unknown device ID

Could be the card is not correctly detected.

But as it stacks completely at the NVIDIA module generation, you should simply go to install without the proprietary Nvidia Modules by using “default” entry on booting the ISO!

You can manually install Nvidia Driver after first boot into the installed system, with our nvidia driver tool:


Will do exactly the same, but you may not have the issue with generating modules.

I will go checking if your issue is general happen now caused by package changes on the arch repos…

And welcome here I am sure we can fix this :enos:

1 Like

I managed to install the os with both the default boot option with online install and the Nvidia boot option with offline install. And were able to boot the system.

However when using nvidia-inst with base install and update the offline install with yay, they both got stuck on dkms install –no-depmod nvidia/550.54.14 -k 6.7.9-arch1-1 as well.

I’m not sure if it changes anything, but I also tried connecting the monitor to the DP port on the motherboard instead of the GPU before running nvidia-inst but it also didn’t work.

Another interesting thing I discovered is that hardware monitor and inxi both works fine normally, but turns nonresponsive when the nvidia driver install/update process got stuck. Not sure if that indicates anything.

simply go replace the dkms one with the default for now will be a workaround.

sudo pacman -Syu nvidia
sudo pacman -R nvidia-dkms

Will be the same driver.

If you want to we can check what exactly went wrong.

what would you like me to do to check?


[liveuser@eos-2024.01.25 ~]$ nvidia-driver-supported-branches
NVIDIA card id: 2702
Fetching driver data from ...

Series 550: supported ( 550.54.14)

NOTE: nvidia-beta-dkms 550.54.14 is an AUR package. To install it, use command:
   yay -S nvidia-beta-dkms

I re-installed the os, it seems there was a kernel update, previously it was 6.7.9-arch1-1 now it is 6.8.1-arch-1-1. And using nvidia-inst I was able to install the driver. So maybe the kernel update fixed the issue.

Thanks for your help! I would have given up half way otherwise.

1 Like

Hi, I seem to have the same issue as described above and found this thread yesterday in hopes it gets solved.
With the new kernel update today, i tried installing eos again. But it didn’t solve the issue for me it looks like.

nvidia-inst tries to install driver version: 550.54.14
as and gets stuck on: dkms install --no-depmod nvidia/550.54.14 -k 6.8.1-arch1-1

Thank you

cool… good to see it was only a hiccup!

extra/nvidia-dkms 550.54.14-5
is current package on repository

Here it only finds AUR package as the package db still holds older version…

go ahead and update mirrors over reflector-simple or other tools. (you will find it on welcome app)

But for you both versions looking okay… @estarik

And indeed a hearty welcome for you too @estarik :enos:

You can go reboot and try again or go to use the non dkms version of the driver instead.
You may do not rebooted after kernel update?

May we should go to include normal nvidia package to nvidia-inst and put dkms optional…

With the non dkms nvidia packages, the install runs fine.
After the reboot and login, there is only the welcome dialog visible. No background or taskbar.

I tried changing the display-manager from the dialog but it fails. When installing after switching to a differen display-manager, the same happened.

Running inxi -G shows nvidia as used driver, so at least that worked i guess.

After 2 hours fiddling around:
Installing enos with cinnamon instead of KDE Plasma and using nvidia-inst results in not beeing able to boot. But the installer did run trough.
→ Module not found nvidia-nvu

Removing dkms and installing regular and I finally can boot into the system and have a desktop.
Switching from lightdm to sddm breaks everything again.

I would like to use KDE instead of plasma. Did anything above help you in understanding the problem?

hmm i bet you wanted to say you would prefer plasma to cinnamon ?

Not clear what exactly you have done here too
installing cinnamon with nvidia boot option from installer results in not booting at all? or fails to start Desktop only? Top be clear this is not a general issue and may different from what the initial poster had…

And for KDE plasma6 you need to check that you switch to X11 session and do not use wayland as long as you have issues. I have also Nvidia GPU and same as many others no problem running plasma 6 on X11. Best not to use autologin feature and on sddm change session to X11 bottom left.

Hello again,

I read this thread

and got X11 to work with the nvidia package (non dkms).

Thank you very much for your help and patience.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.