Online Install hangs at retrieving files

Hey Guys,

I wiped an Arch Distro (guess which one) off my Dell Latitude E6420 i7 8GiB RAM four days ago; still wondering why Arch is top of the pops. I decided to give Arch one last try before installing GhostBSD or other Unix system.

I made a live USB after downloading an iso image; even that was more complex as you cannot use a standard USB creator and have to do it via terminal. Well after all, I had to go on after getting thus far and after six attempts I got the syntax and paths correct.

sudo dd bs=4M if=/home/anglo/Documents/EndeavourOS_Atlantis-21_4.iso of=/dev/sdc conv=fsync oflag=direct status=progress <<

I tried to install Endeavour OS MATE desktop using the “online” facility five times – then tried Lxqt desktop twice; but all failed and stalled at 14% complete where install goes to retrieve packages.

So at midnight I installed the standard “offline” version with encrypted drive and Xfce desktop. It loaded in five minutes then update took fifteen minutes.

It works just fine and is stable so far with minimal apps besides LibreOffice. As GIMP was missing I installed it via the terminal using pacman >$ sudo pacman -S gimp< you can watch as it assembles the package, figures out dependencies and installs latest version – cool.

The previous popular Arch distro would sometimes boot to a locked black screen and would at other times freeze with locked keyboard and mouse

Still have Trisquel OS as daily driver on my lovely old HP G60 laptop but I am forcing myself to use the Dell with other distro – Arch Endeavour.

Then I found the Discovery article: Does EndeavourOS frown upon GUI solutions for Pacman? I started to smile as I read on; is this a spoof? No! Then started to laugh as it continued by which time I was hooked. What an excellent reason for staying with Endeavour. Stability too, thus far. One happy 71 year old pensioner – thanks devs.

Oooooops – just froze for first time in LibreOffice Writer.

https://clbin.com/36bsl

fingers crossed…!

Welcome to the forum! :grin:

Are you trying to make a USB on Linux or windows? I have no problem with popsicle or ventoy.

For the installation time, if it is stuck it’s likely still downloading packages, you can follow the progress in the terminal.

Do you have high speed internet? Did you also update mirrors before installation?

1 Like

The Hulk one? :sweat_smile:

Not sure why marked as solution?

Hey: was following the Discovery - What NOT To Do…. (on linux)

Then “Command Line….The dd command will almost always result in a working Live USB. Just change the paths to the correct paths for your system.”
Had Jumped onto Trisquel but their Live USB create would not recognise the iso!
Not sure of speed at the time; using 4G dongle; it kept saying failed to rate….

I kept watching terminal and disc activity: Terminal jest kept adding screen splashes in a loop; one by one infinitum, for twenty minutes or more.

Thanks guys, shall I make separate post on freeze?

What do you mean by that? No post was marked as solution by you…

For sure, no problem, many different possibilities. Was just wondering why you couldn’t use a disk creator, the ones I posted above worked for me at least.

Sorry - thought ticked boxes were solutions :frowning:

Yes that would be good (since this post is about online install) and add your hardware info and journal log so someone can help. Like you did above. I see that you have Nvidia graphics card. Then someone can help you with the driver install.

I see you have been reading which is great but just in case:

1 Like

Welcome to :enos: forums.

This seems to happen on 4G or poor bandwidth lines. The online install pulls files from the enos repository before starting to install them. During this pull or download period, it goes static and just says “Installing Base System Please Wait” at 14%. It doesn’t show any progress in the terminal log which only shows the list of items which is getting received but no progress.

Until all the files are downloaded the installation progress doesn’t go to go up. It used to show the pacman output in the terminal but Calamres installer doesn’t do that anymore. But this static period kind of scares people (I also panicked when I came across this for the first time).

Hopefully, this would be fixed in the future.

1 Like

Hey thanks again Zircon. Yes I had bookmarked that page early on - it’s all new to me so just copied and paste the command and then clicked the link. Pretty sure it had hardware info first off…? Hope I did this OK…?
If I could ask a stupid question - does the clbin dot com link last forever… :thinking:

1 Like

You do have a working system right?

I don’t know forever, but I posted one last year and it’s still there. It is handy if you just want to refer back to your hardware. But don’t forget that your kernel and drivers may have been updated in the meanwhile.

1 Like

I also have very slow internet. For me to avoid the install to fail, I click on the update mirror in the welcome app, and add the following in the text box on the bottom right next to the list of countries to allow 20s:

--download-timeout 20

Hey Thanks, I wondered what it was doing for 25 minutes…?

Yes me too - but - I am happy with Xfce standard install as it was not bloated with stuff I do not need and the look was cool too. All I had to do was install pacman and GIMP then check for updates now and again. Simple…!
Just need to solve this infrequent freeze but intend to stay as I am warming to Endeavour day by day :heart_eyes:

1 Like

The download does take time depending on the DE/WM user selects. Mirrors transfer rates are slow then it would take more than 25m.

Thanks again :slightly_smiling_face: could kick myself now as at the time trying seven times accumulated into several hours…!
Ah well Xfce is a bit slow but okay and I have knocked FFox into shape.
A bit early to start stressing OS with video editing or multitasking - mmmmm why wait :thinking:

Oh Yes :smiley: Not as fast or efficient as LXDE but still so good to have an escape path from ubuntu-debian based distros :smirk:

I think you mean Pamac?

I hope not. That’s a never ending problem.

Once you get it, then you’ll understand.

I have used mintstick, popsicle, ventoy, and etcher in the last 2 weeks. Popsicle no less than a few hours ago. . . I don’t know where you got this information. What program were you using?? I want to give it a try and test it to see if we can fix the issue. Obviously dd will always work.

With Nvidia?? I’ve had a bunch of dells over the years all very well supported on Linux. Welcome!

Pacman is installed by default, so…