One issue solved, a new one appears

For those who remember, I posted a few issues regarding the GUI. Post 1 Post 2 Post 3

Some issues are fixed with a workaround, or after an update.
But more recently, I noted when I hit the (Nvidia) GPU with a load (Blender render for example), my two external monitors just freeze, and plugging one in/out freezes everything, forcing me to force reboot. But this also happens in some games, and (also with Blender) in Hybrid mode in Optimus. Nvidia only seems to fix it, but it’s annoying, especially when you forget to switch, and even when you switch, you have to logout, and close everything.

What I noticed during all of these posts, there’s one thing in common the GPU.
I have those weird issues since months, thinking they will be solved with updates, but like in programming, you fix one error, you get two. And I don’t really know who to blame, KDE/Plama, or Nvidia/AMD.

I think the die is cast that it’s NVidia :slight_smile: It is indeed the common denominator is probably more than 50% of the problems posted.
I always recommend don’t do NVidia.


All above :wink: :innocent:


Isn’t it usually the one sitting between the keyboard, and chair? :upside_down_face:


then you fault … :rofl: I sure get fix in time


Not always the fault of OS and Sometimes not the fault of hardware sometime its 3rd party apps that are poorly written. I have and Nvidia graphics card that is built into my laptop. Other than screen tearing an issue I was able to fix I haven’t had any other issues with Nvidia.

I also wish to say that the title to this thread is very misleading this is not an EndeavourOS issue


Yup. This one is to blame.

Meh, I can see there is some validity to this however not entirely true. Simple and to the point; I have run Mint and a few other distros for a very long time. EVERY single time I update this OS there is an issue. Hoops have to be jumped through. Files and additional edits need to be made so a base installation will work.

That said, I use older machines so I get that things might get complicated from time to time. What I seldom have an issue with are the updates on the other distros. No, that is not entirely NVIDIA’s fault. I do like this installation, when it works, and to be honest I have never found a more friendly community than here but to blame Nvidia for less than stellar programming really isn’t fair in my opinion.

I would love to see full open source at some point but we are not there yet.

Endevour OS by design has such issues, as a rolling distro. You get newest, with newest issues. You are the tester :smiley:

Endevour OS is not meant to be stable. It is meant to provide benefits of Arch Linux to less advanced users. With advanced problems :confused:

We all know what we sign for :laughing:

But if anyone have some remarks how to make experience more pleasant out of the box, I’m pretty sure maintaners would be open for them.


Simple; many do use Nvidia. If other distros can make it work “out of the box” then we can here. I am not fully versed in programming but can get around in most cases but if we desire to convert and bring micro-crap users over to the “dark side” then we need the basics to function at a minimum. Yes, I understand this is much bigger than my basic interpretation but I am sure you understand my point.

Well, for not being meant to be stable, I’ve never had a more stable OS in my 40+ years of computing. The only other systems that I’ve had as good of luck as EOS were Solaris 7 and AIX 5.3.


Well lets see? :thinking: EndeavourOS is getting better and better! It just works. It’s stable. Very stable. Rolling…always updating. Latest kernels latest software. Lots of options. It’s a :rocketa_purple:




What I’ve seen now, is that a few people blame it on Nvidia.
As (I think) Apple said;

There’s only good hardware, with good software.

But let’s change the topic then, which might require it’s own dedicated post, but also recently came up.
I often experience, when watching YouTube, or downloading/copying stuff, that I get softlocks. See video
The EOS install is on an external SSD, which doesn’t have a DRAM cache. It supports USB 3.1 speeds, but all the ports on my laptop are USB 3.0.

do your logs show any information about what is going on at this particular time? Seems to me to be some kind of communication issue between software / hardware. I’m thinking more software.

1 Like

Systemd logs, or any other logs in particular?

Systemd and Kernel would be my start use the eos log tool

1 Like

Feel free to send me full boot log (journal) would be happy to research on it to see if I can find any hint.
May also from the time when it crashes what indeed would show some interesting outputs. journal to since option can help . Would not recommend to post full journal public…

1 Like

After some trial and error; I think the issue was due that I plugged my drive into a USB-C hub, instead of my laptop directly, because I haven’t noticed any soft-locks so far. ^^

1 Like