On-screen keyboard shift key issue - Gnome 46

After upgrading to GNOME 46 I noticed that the on-screen keyboard has a problem already encountered on older versions of Gnome, and resolved on Gnome 45. In practice, when I click on the shift key to put a capital letter, this remains activated until I I click it again, as if it were the capslock key, which is actually activated by holding down shift key. This behavior is very inconvenient, I think it’s a bug, because on Gnome 45 it worked normally. Furthermore, when I use the keyboard on a terminal and the extended one is activated (which has the capslock key), a duplicate is created.
Also I wonder if it is possible to always force the extended keyboard and not just when using a terminal.
Has anyone encountered this problem? Some advice?
Thank you


Interesting. I had to find out what on-screen keyboard ist. Don’t know for what it is good for.

I enabled it and I have the same behavior you described.

1 Like

The on-screen keyboard is useful for convertible computers that have a touchscreen. On older versions of GNOME (3.xx) that used X11, I used OpenBoard, which is more customizable and allows you to use full layout. Since switching to Wayland it no longer works (I can’t go back to X11 because some programs only work on Wayland). Unfortunately I haven’t found much information about it on the internet.


Thanks for the explanations.

I can imagine that Wayland related things will be fixed over time although this doesn’t help you here.

1 Like