"Ok proxy configuration daemon" forever!

When starting up my HP laptop stops and spins with the following message forever

“Ok proxy configuration demon”

Regardless of which Linux kernel of EndeavourOS, latest updates kernel.

I have been so satisfied and happy with EndeavourOS, about two years. But now really getting tired. Could be an old config file. But I don’t have time to spend hours trying to find what is causing those startup problems. Then the alternative is to find a linux OS that is more conservative and only runs with file/config updates that are safe. But it’s sad to leave EndeavourOS I’ve been happy with EndeavourOS. It’s been about a month since the problem started to appear. Smaller problems that I solved with my many years of knowledge of Linux and now bigger ones that I can’t manage to solve.

Jörgen J

Country Sweden


Kernel: 6.5.9-zen2-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1 Desktop: Cinnamon v: 5.8.4
tk: GTK v: 3.24.38 dm: LightDM Distro: EndeavourOS base: Arch Linux
Type: Laptop System: HP product: HP EliteBook 840 G5 v: N/A serial: Chassis:
type: 10 serial:
Mobo: HP model: 83B2 v: KBC Version 04.6D.00 serial: UEFI: HP
v: Q78 Ver. 01.21.01 date: 07/28/2022
ID-1: BAT0 charge: 29.3 Wh (86.9%) condition: 33.7/50.2 Wh (67.0%) volts: 11.7 min: 11.6
model: Hewlett-Packard Primary serial: status: discharging
Info: quad core model: Intel Core i5-8350U bits: 64 type: MT MCP arch: Coffee Lake rev: A cache:
L1: 256 KiB L2: 1024 KiB L3: 6 MiB
Speed (MHz): avg: 500 high: 800 min/max: 400/3600 cores: 1: 800 2: 800 3: 400 4: 400 5: 400
6: 400 7: 400 8: 400 bogomips: 30399
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Device-1: Intel UHD Graphics 620 vendor: Hewlett-Packard driver: i915 v: kernel arch: Gen-9.5
ports: active: eDP-1 empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2 bus-ID: 00:02.0 chip-ID: 8086:5917
Device-2: Chicony HP HD Camera driver: uvcvideo type: USB rev: 2.0 speed: 480 Mb/s lanes: 1
bus-ID: 1-9:4 chip-ID: 04f2:b5ee
Display: x11 server: X.Org v: 21.1.9 with: Xwayland v: 23.2.2 driver: X: loaded: intel
unloaded: modesetting,vesa alternate: fbdev dri: iris gpu: i915 display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96
Monitor-1: eDP-1 mapped: eDP1 model: ChiMei InnoLux 0x14d4 res: 1920x1080 dpi: 157
diag: 354mm (13.9")
API: EGL v: 1.5 platforms: device: 0 drv: iris device: 1 drv: swrast surfaceless: drv: iris
x11: drv: iris inactive: gbm,wayland
API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 23.2.1-arch1.2 glx-v: 1.4
direct-render: yes renderer: Mesa Intel UHD Graphics 620 (KBL GT2) device-ID: 8086:5917

"Ok starting proxy configuration daemon”

It seems to have calmed down with the boot "Ok starting proxy configuration daemon”. I have no control over what was updated during the day. But I have to check for a few days first before I consider the problem solved.

Jörgen J

The problem is not solved "Ok starting proxy configuration daemon” still goes bananas at the start of my laptop.

Jörgen J

Can anyone help me solve the problem or have any idea what is going on? Or why?

Have you looked at this post?

I thank you “chikenf00t” for your reply. All honor to you “chikenf00t”. Always a success for a community if any member tries to help another user of EndeavourOS.

Looks like I got everything right. Now EndeavourOS is like new again. But the question is whether it would not have been faster to do a new installation. I had saved time.

But the question is what created the problems? I have some thoughts.

I installed TOR + Privoxy on one of two browsers. Not because I have any major use for TOR + Privoxy. But thought that it was possibly justified in some context. I followed the instructions carefully. Yes! It worked great for a long time.

But suddenly these problems began to appear. I don’t know if that’s the right conclusion.

But now the crap is gone and some other things. Now the configuration of EndeavourOS works as it is supposed to work.

But now I have a new problem.

I installed Gnome firmware. There was an update, to Secure Boot dbx 371. I of course restarted my laptop after updating.
But now it has resulted that every time I start the computer or restart the computer I get additional text.

“Reboot is recommended due to the upgrade of core system packages.”

Jörgen J

Can you share what you’re looking at? Also, can you share the output of just a simple yay command to make sure that the message is displaying unnecessarily?

As for your other question, I honestly tried to understand the reading but I’m still not sure what causes that issue. It does seem that it is related to the network config so I would assume your work on TOR and Privoxy had something to do with it.

Recently run update yay. The text is of course partially in Swedish. My language.

jorgenj@jorgen-hpelitebook840g5 ~]$ yay
[sudo] lösenord för jorgenj:
:: Synkroniserar katalogdatabaserna…
endeavouros är ajour
core 132,6 KiB 794 KiB/s 00:00 [----------------------] 100%
extra 8,2 MiB 24,5 MiB/s 00:00 [----------------------] 100%
multilib 141,1 KiB 659 KiB/s 00:00 [----------------------] 100%
:: Söker efter uppdateringar på AUR…
:: Söker efter uppdateringar i databaserna…
:: 1 paket att uppgradera/installera.
1 extra/libuv 1.46.0-1 → 1.47.0-1
==> Paket att hoppa över: (t.ex: “1 2 3”, “1-3”, “^4” eller centralkatalogsnamn)
→ Att exkludera paket kan orsaka partiella uppgraderingar och ha sönder system
Sync Dependency (1): libuv-1.47.0-1
:: Synkroniserar katalogdatabaserna…
endeavouros är ajour
core är ajour
extra är ajour
multilib är ajour
:: Påbörjar fullständig uppgradering…
Reder ut beroenden…
Letar efter krockar mellan paket…

Paket (1) Gammal version Ny version Nettoskillnad Storlek vid hämtning

extra/libuv 1.46.0-1 1.47.0-1 0,00 MiB 0,23 MiB

Att hämta: 0,23 MiB
Storlek efter installation: 0,58 MiB
Nettouppgraderingsstorlek: 0,00 MiB

:: Vill du fortsätta till installationen? [J/n] J
:: Hämtar paketen…
libuv-1.47.0-1-x… 240,5 KiB 3,31 MiB/s 00:00 [----------------------] 100%
(1/1) Kontrollerar nycklarna i nyckelringen [----------------------] 100%
(1/1) Kontrollerar paketintegriteten [----------------------] 100%
(1/1) Läser in paketfiler [----------------------] 100%
(1/1) Letar efter krockar mellan filer [----------------------] 100%
:: Verkställer ändringar…
(1/1) Uppgraderar libuv [----------------------] 100%
:: Utför åtgärder som krokats i efter transaktionen…
(1/3) Arming ConditionNeedsUpdate…
(2/3) Cleaning pacman cache…
==> no candidate packages found for pruning
(3/3) Checking which packages need to be rebuilt
[jorgenj@jorgen-hpelitebook840g5 ~]$

Looks fine to me. Try restarting again and see if the message is still appearing.

No! It didn’t work. Same problem.

Ah, to be honest I’m not sure how that script works. I’m pretty sure it’s an EOS thing, though. Maybe @manuel would be able to chime in. Fortunately, it’s not as major as the original problem :slight_smile:

I actually have the same thought as you. That the script may need to be fixed. But thanks for all the help. :grinning:/Jörgen J

1 Like

Sorry for the late reply.

I can’t reproduce the reboot recommendation issue here (on KDE), so it could be something Cinnamon related, or related to some other program, like the kernel, wayland, or the notify service.

So if you try another kernel, does the issue still occur?
Or with x11 instead of wayland?

1 Like

Thanks manuel, (EndeavourOS app team) for engaging with my issues as well. It seems I solved my problems. Explaining how and all the steps becomes far too complicated. You can say briefly that the one conclusion led me on to a final solution.

But that wayland was somehow involved can probably be a correct conclusion.

I also changed to gdm.

Now I don’t have strange messages about restarting the computer for updates that don’t require a restart.

As for the first issue I asked about, I am now absolutely certain that the blueman applet was part of the cause of the issues. I don’t have a concrete or good answer to why the blueman applet created problems.

But when I changed to gnome-bluetooth all the strange startup issues went away. "bootup looping on “starting proxy configuration daemon”

I don’t know if I’m right.

Jörgen J

1 Like