Oh My ZSH does not work

I installed oh my zsh in my Endeavour OS as I did in Manjaro and Debian, but when I run the source .zshrc nothing happens.
What’s missing, please?

Well, just try this tutorial: https://forum.manjaro.org/t/all-the-fun-with-oh-my-zsh-imported-from-old-forum/3434

You may have to deinstall grml-zsh-config package.

Thank you for your help :wink:
I tried this way, but still nothing.

Thank you for your help.
I tried this way too, however, still nothing.
The real problem is I can’t change the Theme. My present-insistent-unchangeable theme is this one:

I desinstalled the grml-zsh-config as u suggested, but the result was worse, no theme ;(
Thus I had to reinstall it, but I’m in zsh and there’s a theme, but, for now, inexplicably unchangeable.

But we won’t waste our time trying to fix that. Let’s keep on with more important issues.

Thank you all!

Maybe you need to completely remove all .zsh files in order to remove crippled configs. After reinstall of oh my zsh there should be a working config.

1 Like

If you are still interested in this, I was successful with the following steps:

Remove grml-zsh-config

sudo pacman -Rs grml-zsh-config

Change shell to zsh

chsh -s /usr/bin/zsh

Remove existing .zshrc

rm .zshrc

Get oh my zsh

sh -c "$(curl -fsSL https://raw.githubusercontent.com/robbyrussell/oh-my-zsh/master/tools/install.sh)"

.zshrc now should be default config from oh my zsh:

➜  ~ more .zshrc
# export PATH=$HOME/bin:/usr/local/bin:$PATH

# Path to your oh-my-zsh installation.
export ZSH="/home/csteinforth/.oh-my-zsh"

# Set name of the theme to load --- if set to "random", it will
# load a random theme each time oh-my-zsh is loaded, in which case,
# to know which specific one was loaded, run: echo $RANDOM_THEME
# See https://github.com/robbyrussell/oh-my-zsh/wiki/Themes
ZSH_THEME="robbyrussell"

# Set list of themes to pick from when loading at random
# Setting this variable when ZSH_THEME=random will cause zsh to load
# a theme from this variable instead of looking in ~/.oh-my-zsh/themes/
# If set to an empty array, this variable will have no effect.
# ZSH_THEME_RANDOM_CANDIDATES=( "robbyrussell" "agnoster" )
.....
2 Likes

This time it ran simply flawlessly :wink:
oh-my-zsh is running correctly.
Thank you very much, @csteinforth.