Odd locale behaviour

Firstly, apologies if this is posted in the wrong place, since it only affects software that isn’t the DE I figured it could go here but I’m not entirely sure.

Since KDE 5.27 makes fractional scaling actually viable I am back on endeavour with my LG Gram.
Got a fresh install set up today and everything is working great other than an odd language quirk.

I installed the OS with en_GB as the language however I am currently learning Japanese so I wanted to get that configured as an option (also to fix font rendering).

To do this I uncommented ja_JP.UTF-8 in locale.gen and ran the locale-gen. I then installed a few fonts and added Japanese as a locale within KDE (Below English). This all appeared to work fine, my font rendering issues were corrected and I can launch applications in Japanese using environment variables.

However, while the majority of the UI and apps are still displaying in English as I want, there are a couple of programs (namely darktable and sudo that I’ve noticed so far) that display in Japanese. If I launch them and manually specify LANGUAGE=en_GB.utf8 they run correctly in English. But launching without any arguments loads in Japanese. My guess is there is some file somewhere that is setting the language incorrectly but I cannot figure out where. My “/etc/locale.conf” is set to en_GB and there is nothing in my “$XDG_CONFIG_HOME/locale.conf”

Has anyone else experienced something similar or know how to fix this?


Figured it out.
~/.config/plasma-localerc had LANGUAGE set to en_GB:ja, that was the file I was looking for but couldn’t figure out.

(/etc/default/keyboard as mentioned above was set correctly)

Fixed that and now it all works correctly.

1 Like

Nice! Please, post old and new values of LANGUAGE key, for future reference.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.