Odd Chromium Font

No matter which windows manager I use or linux version, I keep getting this odd default font on chromium when installed under snap/flatpak.

I tried changing all fonts on chromium itself and within the system theme, still nothing.

Here is what it looks like:

google1

What about chromium from the repos?
Chromium is there in the archlinux arm repos. I don’t have this issue with that one.

I get the same issue with the repos as well. I dont have this issue on any x86/x64 systems.

What DE are you using? I don’t have this issue on either MATE or Plasma.
I tried chromium only on these two. I use firefox on linux.

Did you try our arm installer? What device do you have? Can you do a fresh install and confirm the issue?

The platform is odroid n2+. The DE’s ive used are mate, gnome, kde. Distros Ive used are arch, ubuntu (22 & 20) + debian 11. It happens across the board.

Here is EndeavourOS ARM on odroid N2+ with chromium from the repos
Screenshot_20220808_175505

1 Like

Not sure why its happening here over multiple platforms and reinstalls. I wish I knew the font setting that was being changed so I could change it to something else.