OBS studio flatpak version does not support virtual camera

I’m trying to enable the virtual camera option on OBS 30 installed via flatpak. I installed the flatpak version because I also need the obs-websocket server to be able to change scenes and the pacman version does not have this possibility. How could I solve this problem?
I’m using EndeavourOS build 2024.01.25 with Gnome 45.5 on Wayland (kernel: Linux 6.8.9-zen1-1-zen)
Thanks a lot
simdll

You might consider using obs-studio-tytan652 in the AUR. It includes obs-websocket.

I’ve been able to depend on this version for my professional event streaming work, although I don’t use the websocket element. I can confirm the virtual camera works well.

1 Like

Thank you for the suggestion. The websocket seems work well, but the virtual camera option is not showed:
image
I start obs with --startvirtualcam option, but I get the same result.
Maybe I forgot to install or configure samething?
Thanks
simdll

Does regular OBS from the official Arch Repo not have this feature? I’m almost sure I remember using it with DroidCam in the past.

Yes official OBS studio has virtual camera, but don’t have web socket (https://wiki.archlinux.org/title/Open_Broadcaster_Software#Global_shortcuts_in_KDE_not_working).
I need of it because on Wayland global shortcut doesn’t work, and web socket is the only way to change or manage scene when OBS hasn’t the focus.

So… It’s because you’re using Wayland or is it also not available on X11? :thinking:

Again, I am almost sure I’ve used a virtual camera with DroidCam from my smartphone (both with Wi-Fi and via USB).

The fact that I remember so much makes me absolutely sure to be honest. The only thing is I can’t remember if it was while I was on Windows or Linux or both. So maybe it’s a Linux issue.

1 Like

Are you able to confirm you’ve installed
v4l2loopback-dkms
and optionally
v4l2loopback-utils
? This is needed for virtual camera support.

# yay -Q | grep v4l2loopback

Starting from version 26.1, OBS supports virtual camera output on Linux. To use it, install v4l2loopback, then the Start Virtual Camera button will appear in OBS. If the v4l2loopback kernel module is not loaded yet, OBS will automatically try to load it and ask for administrative privileges to do so (using pkexec(1)).

https://wiki.archlinux.org/title/Open_Broadcaster_Software#Virtual_camera_output

1 Like

Yes v4l2loopback pakages is installed:
image
But the commant do enable it (sudo modprobe v4l2loopback) fail:
modprobe: FATAL: Module v4l2loopback not found in directory /lib/modules/6.8.9-zen1-2-zen
Starting OBS with obs --startvirtualcam command it not work, probably because kernel module isn’t enabe. I try to reinstall them and the output is:

:: Esecuzione degli hook di post-transazione...
(1/4) Arming ConditionNeedsUpdate...
(2/4) Install DKMS modules
==> dkms install --no-depmod v4l2loopback/0.13.1 -k 6.8.9-arch1-2
==> depmod 6.8.9-arch1-2

What can I try?
Thanks for help
simdll

If I don’t wrong DroidCam was developed for use the phone camera as PC webcam. My problem is that obs virtual camera (used to “export” obs scene and use it on meetinfg software, as google meet) is not enable

Yes, I used to use DroidCam with my phone’s camera and SnapCamera, while using Skype.

Phone Camera → SnapCamera (virtual camera) → Skype

So, yeah, it was definitely on Windows.

1 Like

Do you have headers installed for your current kernel as well?

So if using the standard kernel, you’d need the have linux-headers installed.

See headers for other kernels here.

1 Like

Yes, I forgot to install heders for zen kernel, in my case linux-zen-headers.
Thanks a lot for the support and hepl
simdll

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.