NVME SSD not detected Dell Laptop

I just upgraded from my old laptop to an Dell Latitude 7290 and I got a new Samsung SSD for this upgrade.

lsblk and the pre-installed partition manager doesn’t seem to detect it. It only can see the flash drive.
I tried to flash the latest iso I downloaded today (14.01 ) in ISO mode, in DD mode, with UEFI/BIOS, with UEFI only, disabled everything that has to do with boot and TPM, updated BIOS to the latest version but nothing helps. I booted with external DVD/BD drive my Windows 7 Ultimate DVD and also Windows 8.1 but on Winbloat it seems to detect the SSD and it doesnt have any partitions.
Does anyone have any solutions besides running sudo pacman -Syyu in the terminal ?
This laptop and my old, broken ThinkPad have the same brand new Samsung SSD with the same capacity but with the Thinkpad on older EOS release I didn’t face such issue even with TPM and Secure Boot enabled : /

Booting the USB drive in Legacy mode doesn’t also help there.
I also tried to remove the SSD and plug it into a USB C adapter seems to work at first but once I start the installer, it just fails to install and the installer shows me an error that the SSD has an I/O write error. I tried it with older SSD and exact the same results with SSD plugged into laptop (not detecting it) and into the adapter

I might be wrong but as for internal SSD Latitude 7290 supports M.2 only
like Kingston 500GB NV2 SSD M.2
If your USB adapter works try gparted to create a gpt partition table, (but even using USB 3.1 it will not work at max speed.)

Have you checked the settings in the Bios for RAID. Make sure it’s off and set SATA to ahci.

Edit: I think the boot loader already has nvme_load=YES so this is the only thing i can think of at the moment to check.

As far as I read on the OEM setup manual that came with this laptop, you can plug any m.2 pcie nvme ssd from gen 2 and what’s funny is the fact that it also supports m.2 SATA SSD.
The thing with Gparted didn’t work but I figured out the issue

Yeah, since Linux Kernel 3.x or 2.x NVME load is set automatically to “yes” and yeah, it’s kinda stupid to say but the SATA Option which showed options SATA Off, SATA AHCI and RAID was set to SATA Off option : P
But it’s kinda strange that this option was valid for NVME PCIE SSD because this laptop supports SATA m.2 and PCIE m.2 SSD’s.
But yeah, it turns out if this is set to off, the SSD isn’t recognized by “alternate OS’s” and only Windows seems to work with this setting.

Well, at least it works now.
Thank you very much for help

1 Like

I think there are some instances where SATA needs to be set to off with certain Pci-e SSD.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.