Nvidia-settings isn't remembering my config changes

So I have a 75Hz panel and every time I boot firefox has horrible screen tearing (tested in i3 and xfce). I figured out this goes away completely when I manually change display config (using the GUI) from auto to 1080p 75Hz, so clearly it’s defaulting to 60Hz.

But every time I boot the settings reset. I’m sure I can solve it by clicking “save X config file” in the settings but I don’t know where Nvidia expects this file. Does anyone know?

$ whereis nvidia-settings

o

$ which nvidia-settings

I’ve never used Nvidia so far, maybe in a few days … we’ll see …

This might help. I have the same Nvidia GTX 1060 and i think when i installed it creates a .conf file.

https://wiki.archlinux.org/index.php/NVIDIA#NVIDIA_Settings

Edit: I’m not sure exactly what changes you mean but when i click on advanced and make a change and apply it wants to save it to the file and gives an option to save it to another. I just let it default to the current and i quit and all is good. That doesn’t give you a back up of the original though and your right it doesn’t show where it’s saved.

1 Like

yeah nvidia-settings have sort of two models that saves config… one as @ricklinux notified,

but more up you have also one save part ‘X’ , thats basicly the xorg.conf.

check which conf u use in /etc/X11/xorg.conf.d/ you have to check what in that text file then rename it to as 20-nvidia.conf and copy those to /etc/X11/xorg.conf.d/

i think some tearing options downunder the menu can do as the link descriped ; and must be in autostart.

but the X config above the menu is basicly the xorg.conf but xorg.conf is decapriated. you have to check the config and rename and config to the xorg.conf.d folder as 20-nvidia.conf

but would be nice if someone can confirm , is a while back i used those, last years are opensource drivers :slight_smile:

To load the ~/.nvidia-settings-rc (default file nvidia-settings gui will save) for the current user run this at startup:
nvidia-settings --load-config-only
you can use whatever your Desktop Environment is providing to start a script on login…

xfce4:

I managed to save config to the xorg.conf.d folder as 20-nvidia.conf, this part works.

However, the settings part won’t load. Even with autostart settings.
First I got an error when loading nvidia-settings --load-config-only through terminal.
The error was something with Local C language. This I got fixed by changing the local to default in Regional settings.

Then I retried loading the settings through terminal, this time no error, but also no change in the ‘nvidia-settings’.

What may I have overlooked here?

PS. I’m using KDE as DE.

PSS. Using with -V command I get the following:
ERROR: Unable to find display on any available system
That’s interesting, I’m using only nVidia card with no built-in display.

lspci -nnk | grep VGA
08:00.0 VGA compatible controller [0300]: NVIDIA Corporation GM204 [GeForce GTX 970] [10de:13c2] (rev a1)

nvidia-smi
nvidia smi

https://wiki.archlinux.org/index.php/KDE#Autostart

It took a while, but after reinstalling my PC with the latest ISO and another graphic card GTX1660 (GTX970 died) all seems to work now.

What I did is:

  1. Terminal: sudo nvidia-settings
  2. I checked “Force Full Composition Pipeline” under the “X Server Display Configuration (Advanced)”
  3. Then save “Save to X Configuration File” as “/etc/X11/xorg.conf.d/20-nvidia.conf”
  4. Close nvidia-settings
  5. Repeat step 1
  6. Make changes from “X Screen 0” to your desired settings, example “OpenGL Settings”, “Antiliasing Settings”, “PowerMizer”, etc.
  7. Go to “nvidia-settings Configuration” and press on “Save Current Configuration”
  8. Save it to the path: /home/USERNAME/.nvidia-settings-rc
  9. Reboot and check if the settings has loaded in nvidia-settings.

For me this worked without any issue.

There have been some issues with Nvidia lately. There is a new wiki with additional information here.

1 Like