Nvidia Screen Tearing

Hi there, hope everyone is doing great.
So I’ve installed EndeavourOS KDE, and installed nvidia drivers with optimus manager qt successfully.
But I’m having screen tearing issues, tried force full composition pipeline,set vsync prevention to never and rebooted, but i still have screen tearing when scrolling or sometimes moving a window.
Some details :
Nvidia gpu : Geforce GTX 1050 Mobile
Kernel : linux zen with linux zen headers installed
shell : fish
Thanks for your attention.

Welcome aboard!!

Please post the output of inxi -Fxxxza --no-host.

Welcome @kingz



System:    Kernel: 5.10.5-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 10.2.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-linux-zen root=UUID=40807d86-1906-4b08-9288-371f68a74e8d rw quiet loglevel=3 

Graphics:  Device-1: Intel HD Graphics 630 vendor: Lenovo driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:591b 
           Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] vendor: Lenovo driver: nvidia v: 460.32.03 
           alternate: nouveau,nvidia_drm bus ID: 01:00.0 chip ID: 10de:1c8d 
           Device-3: Chicony EasyCamera type: USB driver: uvcvideo bus ID: 1-6:2 chip ID: 04f2:b57e serial: <filter> 
           Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: modesetting,nvidia unloaded: intel display ID: :0 
           screens: 1 
           Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9") 
           Monitor-1: eDP-1-1 res: 1920x1080 hz: 60 dpi: 142 size: 344x194mm (13.5x7.6") diag: 395mm (15.5") 
           OpenGL: renderer: GeForce GTX 1050/PCIe/SSE2 v: 4.6.0 NVIDIA 460.32.03 direct render: Yes 

If you need more information let me know.

Welcome aboard! :smile:

Please show the output of:

lspci -vnn | grep -PA9 'VGA|Display|3D'
lsmod | grep -P 'nouveau|nvidia|i915'

One thing that might help is to uninstall xf86-video-intel.

Edit: fixed missing single quote.

Alright, but I need intel drivers because sometimes I use my laptop on battery.

lspci -vnn | grep -PA9 'VGA|Display|3D'                                                       
00:02.0 VGA compatible controller [0300]: Intel Corporation HD Graphics 630 [8086:591b] (rev 04) (prog-if 00 [VGA controller])
        Subsystem: Lenovo Device [17aa:39d1]
        Flags: bus master, fast devsel, latency 0, IRQ 129
        Memory at a2000000 (64-bit, non-prefetchable) [size=16M]
        Memory at b0000000 (64-bit, prefetchable) [size=256M]
        I/O ports at 5000 [size=64]
        Expansion ROM at 000c0000 [virtual] [disabled] [size=128K]
        Capabilities: <access denied>
        Kernel driver in use: i915
        Kernel modules: i915
01:00.0 3D controller [0302]: NVIDIA Corporation GP107M [GeForce GTX 1050 Mobile] [10de:1c8d] (rev a1)
        Subsystem: Lenovo Device [17aa:39d1]
        Flags: bus master, fast devsel, latency 0, IRQ 133
        Memory at a3000000 (32-bit, non-prefetchable) [size=16M]
        Memory at 90000000 (64-bit, prefetchable) [size=256M]
        Memory at a0000000 (64-bit, prefetchable) [size=32M]
        I/O ports at 4000 [size=128]
        Capabilities: <access denied>
        Kernel driver in use: nvidia
        Kernel modules: nouveau, nvidia_drm, nvidia

and the second command doesn’t show anything for some reason.

Have you tried kwin-lowlatency? I think this should help with tearing. If not, try and move to compton.

Oops, the single quote is missing from the end:

lsmod | grep -P 'nouveau|nvidia|i915'

Did you check and set triple buffering and other options?



Section "Device"
        Identifier "Nvidia Card"
        Driver     "nvidia"
        VendorName "NVIDIA Corporation"
        BoardName  "GeForce GTX 1050 Ti"

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    Option         "metamodes" "nvidia-auto-select +0+0 {ForceFullCompositionPipeline=On}"
    Option         "AllowIndirectGLXProtocol" "off"
    Option         "TripleBuffer" "on"

I have it written exactly like this I just replaced Ti with Mobile.

as Nvidia Driver seems to be configured nicely to get the best out of it, i would bet on plasma setting themself to tweak also is tearing all over the DE and all apps or only on some apps like browser?

1 Like