Nvidia Optimus set up, driver not loaded error

Hi everyone, I’m struggling to get my optimus laptop set up (1069 Max Q & I7-7700HQ ; machine is a Dell 7577). I tried following this forum guide, but encounter an in issue very early on, with an error message saying my driver is not loaded. Any ideas on how to fix this?

very early on following the tutorial? or an reboot ?
on what point of the tutorial does you get the error?

What is the output of hwinfo --gfxcard?
You might have to install hwinfo first.

Hi there and thanks for getting back to me so quickly, sorry about the lack of information I was on mobile at the time.

The problem I’m getting is that after running the
nvidia-installer -b option and rebooting I get

ERROR: NVIDIA driver is not loaded
ERROR: Unable to load info from any available system

Output of hwinfo -gfxcard below

hwinfo --gfxcard
19: PCI 100.0: 0300 VGA compatible controller (VGA)             
  [Created at pci.386]
  Unique ID: VCu0.K+8ANZ62bVB
  Parent ID: vSkL.TOzXQuj5Pq7
  SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:00.0
  SysFS BusID: 0000:01:00.0
  Hardware Class: graphics card
  Model: "nVidia GP106M [GeForce GTX 1060 Mobile]"
  Vendor: pci 0x10de "nVidia Corporation"
  Device: pci 0x1c20 "GP106M [GeForce GTX 1060 Mobile]"
  SubVendor: pci 0x1028 "Dell"
  SubDevice: pci 0x0802 
  Revision: 0xa1
  Memory Range: 0xdc000000-0xdcffffff (rw,non-prefetchable,disabled)
  Memory Range: 0xb0000000-0xbfffffff (ro,non-prefetchable,disabled)
  Memory Range: 0xc0000000-0xc1ffffff (ro,non-prefetchable,disabled)
  I/O Ports: 0xe000-0xe07f (rw,disabled)
  Memory Range: 0xdd000000-0xdd07ffff (ro,non-prefetchable,disabled)
  IRQ: 255 (no events)
  Module Alias: "pci:v000010DEd00001C20sv00001028sd00000802bc03sc00i00"
  Driver Info #0:
    Driver Status: nouveau is not active
    Driver Activation Cmd: "modprobe nouveau"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #15 (PCI bridge)

31: PCI 02.0: 0300 VGA compatible controller (VGA)
  [Created at pci.386]
  Unique ID: _Znp.Fh5u13BRIw2
  SysFS ID: /devices/pci0000:00/0000:00:02.0
  SysFS BusID: 0000:00:02.0
  Hardware Class: graphics card
  Device Name: "Onboard IGD"
  Model: "Intel HD Graphics 630"
  Vendor: pci 0x8086 "Intel Corporation"
  Device: pci 0x591b "HD Graphics 630"
  SubVendor: pci 0x1028 "Dell"
  SubDevice: pci 0x0802 
  Revision: 0x04
  Driver: "i915"
  Driver Modules: "i915"
  Memory Range: 0xdb000000-0xdbffffff (rw,non-prefetchable)
  Memory Range: 0x70000000-0x7fffffff (ro,non-prefetchable)
  I/O Ports: 0xf000-0xf03f (rw)
  Memory Range: 0x000c0000-0x000dffff (rw,non-prefetchable,disabled)
  IRQ: 145 (98764 events)
  Module Alias: "pci:v00008086d0000591Bsv00001028sd00000802bc03sc00i00"
  Driver Info #0:
    Driver Status: i915 is active
    Driver Activation Cmd: "modprobe i915"
  Config Status: cfg=new, avail=yes, need=no, active=unknown

Primary display adapter: #19

So the graphics card show up just fine, just the driver doesn’t get loaded at all. I read something about the dkms version, is this something I should be using instead?

Thanks again!

What does inxi -G show

Graphics:  Device-1: Intel HD Graphics 630 driver: i915 v: kernel 
           Device-2: NVIDIA GP106M [GeForce GTX 1060 Mobile] driver: N/A 
           Display: x11 server: X.Org 1.20.8 driver: intel unloaded: fbdev,modesetting,vesa 
           resolution: 1920x1080~60Hz 
           Message: Unable to show advanced data. Required tool glxinfo missing. 

GPU shows up here too

Ya it doesn’t look like the Nvida driver is loaded. I thought that the nvidia-installer was just a tool? Anyway you can run it in test mode to install the dkms version.

nvidia-installer-dkms -b -t

If there are no errors you can then install it but i think you need to use sudo

Edit: yes this is correct

nvidia-installer-dkms -b -t      # a test run only - stop if this fails!
    sudo nvidia-installer-dkms -b   # real driver install

I didn’t have the dkms version installed so I pulled the from the AUR and had to replace the nvidia-installer with it. This resulted in a conflict between bbswitch and bbswitch-dkms. After removing the former the install worked fine as it had with just nvidia-installer but when checking on the result with nvidia-settings I am getting the exact same error.

I checked hwinfo again and there’s 3 drivers mentioned nouveau, nvidia_drm and nvidia. Should I try activating one of those using modprobe`??

I don’t really have any experience with bumblebee and optimus only the latest desktop Nvidia cards and i do use the dkms version. The hybrid graphics are somewhat a different beast but the guide has all the steps. Sorry i don’t have an answer other than what’s there. Basically it looks like installing the Optimus manager and disabling bumblebee and then switching to the Nvidia. So the Optimus allows to switch back and forth from Intel and Nvidia.

What’s the output of yay -Qs nvidia and yay -Qs bumblebee?

yay -Qs nvidia
local/bumblebee 3.2.1-20
    NVIDIA Optimus support for Linux through VirtualGL
local/lib32-nvidia-utils 440.82-1
    NVIDIA drivers utilities (32-bit)
local/libvdpau 1.3-1
    Nvidia VDPAU library
local/libxnvctrl 440.82-1
    NVIDIA NV-CONTROL X extension
local/nvidia 440.82-3
    NVIDIA drivers for linux
local/nvidia-dkms 440.82-1
    NVIDIA drivers - module sources
local/nvidia-installer-db 2.2-1
    Database for the script to setup nvidia drivers in EndeavourOS
local/nvidia-installer-dkms 3-2
    Script to setup nvidia drivers (dkms version) in EndeavourOS
local/nvidia-settings 440.82-1
    Tool for configuring the NVIDIA graphics driver
local/nvidia-utils 440.82-1
    NVIDIA drivers utilities

and for bumblebee

[nb@nb-7577 ~]$ yay -Qs bumblebee
local/bumblebee 3.2.1-20
    NVIDIA Optimus support for Linux through VirtualGL

When trying to activate the driver using modprobe nvidia or I get a module not found error

modprobe: FATAL: Module nvdia not found in directory /lib/modules/5.6.3-arch1-1

You should uninstall either nvidia or nvidia-dkms.

I have uninstalled the dkms version but get the same result…

I am really quite confused about what I’m doing wrong here. Should I activitate driver first using modprobe? If yes should I be picking nvidia or nvidia_drm?

Thanks everybody for your help so far, I got it to work!

as suggested by @manuel I removed all nvidia-dkms related packages including bbswitch-dkms and the downloaded nvidia driver just to be sure. I then ran

sudo nvidia-installer -b

After this i still got the same error so I decided to just try modprobe nvidia and this worked! I then followed the rest of the tutorial by installing optimus-manager-qt disabling bumblebeed.service and enabling optimus-manger.service

Well at least a to some extent…
I got Optimus-manager installed and can switch between the all different options and they do work so that’s a fantastic start!

However, I am facing a slight issue with setting up my 2nd monitor. When in hybrid mode I don’t get an image whatsoever and while nvidia-settings does show it, there is no way to configure it. Additionally xrandr shows it as disconnected.

When set to Nvidia the second screen gets detected and I get set-up everything with xrandr.

So how can I get the 2nd screen to work in hybrid mode? I know this is technically possible because it worked just fine under Manjaro KDE.

I’m using just I3 at the moment so configuration without GUI’s is still something rather new to me

How did you end up getting it to work finally? What desktop are on?

Edit: Here’s a little bit of info that may help you.