Nvidia is getting too hot & video play is rather slow (proprietary driver)

Hello community,

I have played with this distro for some days now, mainly on KDE, and I found it very cool, interesting and actually pretty easy to use! (even though it’s terminal-centered).

My issue is with Nvidia which is getting too hot, reached 50+ degrees and it actually goes to 55 but then the coolers kick in hard to bring it down. This is happening while I have only a browser and 5-10 tabs opened with a minimum number of apps installed.

I saw that Nouveau (according to Lm_Sensors and psensor) stays pretty much at 38-39. How is this possible?

Anyway, I tried 515xx but also 470xx and it’s the same. I tried via dkms but also via nvidia-inst. In the end, I found it rather easy to install the drivers from the terminal with these commands.

However, be it Nouveau or proprietary, the videos (youtube but mostly on VLC) seem a little sluggish, slow, with the framerate and video-audio sync being not totally acting natural, so to speak.

I don’t think there would an issue with the driver installation. Maybe there is some configuration issue? For example, in the Nvidia X Server Settings, sure, I can enable the Fan settings and set them how I want and keep it cool (although it should work okay even without that) but the quality of the framerate/sync is still not satisfactory.

What do you think I should do? How can I resolve the heat + video play ?

Here is my spec:

inxi -Fza
  Kernel: 5.15.63-1-lts arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-linux-lts
    root=UUID=07c62d00-d47a-49b1-a732-38ce0c79e66c rw loglevel=3 nowatchdog
    nvme_load=YES nvidia-drm.modeset=1
  Desktop: KDE Plasma v: 5.25.4 tk: Qt v: 5.15.5 wm: kwin_x11 vt: 1
    dm: SDDM Distro: EndeavourOS base: Arch Linux
  Type: Desktop Mobo: Gigabyte model: B365M H v: x.x
    serial: <superuser required> UEFI: American Megatrends v: F3
    date: 09/05/2019
  Info: model: Intel Core i5-9400F bits: 64 type: MCP arch: Coffee Lake
    gen: core 9 built: 2018 process: Intel 14nm family: 6 model-id: 0x9E (158)
    stepping: 0xA (10) microcode: 0xF0
  Topology: cpus: 1x cores: 6 smt: <unsupported> cache: L1: 384 KiB
    desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB L3: 9 MiB
    desc: 1x9 MiB
  Speed (MHz): avg: 800 min/max: 800/4100 scaling: driver: intel_pstate
    governor: powersave cores: 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800
    bogomips: 34798
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
  Type: mds mitigation: Clear CPU buffers; SMT disabled
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT disabled
  Type: retbleed mitigation: IBRS
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: IBRS, IBPB: conditional, RSB filling,
    PBRSB-eIBRS: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA TU117 [GeForce GTX 1650] vendor: Gigabyte driver: nvidia
    v: 515.65.01 alternate: nouveau,nvidia_drm non-free: 515.xx+ status: current
    (as of 2022-07) arch: Turing code: TUxxx process: TSMC 12nm
    built: 2018-22 pcie: gen: 3 speed: 8 GT/s lanes: 16 ports: active: none
    off: DP-1,HDMI-A-1 empty: HDMI-A-2 bus-ID: 01:00.0 chip-ID: 10de:1f82
    class-ID: 0300
  Display: x11 server: X.Org v: 21.1.4 compositor: kwin_x11 driver: X:
    loaded: nvidia unloaded: modesetting alternate: fbdev,nouveau,nv,vesa
    gpu: nvidia,nvidia-nvswitch display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3600x1080 s-dpi: 90 s-size: 1016x301mm (40.00x11.85")
    s-diag: 1060mm (41.72")
  Monitor-1: DP-1 mapped: DP-0 note: disabled pos: primary,left
    model: Dell S2522HG serial: <filter> built: 2021 res: 1920x1080 dpi: 90
    gamma: 1.2 size: 544x303mm (21.42x11.93") diag: 623mm (24.5") ratio: 16:9
    modes: max: 1920x1080 min: 640x480
  Monitor-2: HDMI-A-1 mapped: HDMI-0 note: disabled pos: right
    model: NEC E223W serial: <filter> built: 2015 res: 1680x1050 hz: 60 dpi: 90
    gamma: 1.2 size: 474x296mm (18.66x11.65") diag: 559mm (22") ratio: 16:10
    modes: max: 1680x1050 min: 640x480
  OpenGL: renderer: NVIDIA GeForce GTX 1650/PCIe/SSE2 v: 4.6.0 NVIDIA
    515.65.01 direct render: Yes
  Device-1: Intel 200 Series PCH HD Audio vendor: Gigabyte
    driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 chip-ID: 8086:a2f0
    class-ID: 0403
  Device-2: NVIDIA vendor: Gigabyte driver: snd_hda_intel v: kernel pcie:
    gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 01:00.1 chip-ID: 10de:10fa
    class-ID: 0403
  Sound Server-1: ALSA v: k5.15.63-1-lts running: yes
  Sound Server-2: PulseAudio v: 16.1 running: no
  Sound Server-3: PipeWire v: 0.3.56 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Gigabyte driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: d000 bus-ID: 07:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp7s0 state: up speed: 100 Mbps duplex: full mac: <filter>
  Local Storage: total: 1.18 TiB used: 184.32 GiB (15.2%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Kingston model: SA400S37240G
    size: 223.57 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: B1D2 scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Western Digital
    model: WD10EZEX-60WN4A1 size: 931.51 GiB block-size: physical: 4096 B
    logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter>
    rev: 1A03 scheme: GPT
  ID-3: /dev/sdc maj-min: 8:32 type: USB vendor: Kingston
    model: DataTraveler 3.0 size: 57.73 GiB block-size: physical: 512 B
    logical: 512 B type: N/A serial: <filter> rev: 0000 scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
  ID-1: / raw-size: 48.83 GiB size: 47.76 GiB (97.81%) used: 17.46 GiB
    (36.6%) fs: ext4 dev: /dev/sda5 maj-min: 8:5
  ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%) used: 312 KiB
    (0.1%) fs: vfat dev: /dev/sda3 maj-min: 8:3
  ID-3: /home raw-size: 34.18 GiB size: 33.35 GiB (97.56%) used: 1.19 GiB
    (3.6%) fs: ext4 dev: /dev/sda6 maj-min: 8:6
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 20 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/sda4 maj-min: 8:4
  System Temperatures: cpu: 39.0 C mobo: N/A gpu: nvidia temp: 43 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 54%
  Processes: 214 Uptime: 14m wakeups: 0 Memory: 15.57 GiB used: 3.49 GiB
  (22.4%) Init: systemd v: 251 default: graphical tool: systemctl
  Compilers: gcc: 12.2.0 Packages: pacman: 1024 lib: 261 Shell: Bash
  v: 5.1.16 running-in: konsole inxi: 3.3.20

50-55°C is not too hot at all don’t worry.
Did you try to enable GPU acceleration?
In Firefox go to about:config > media.ffmpeg.vaapi.enabled > true
In VLC I think there is a GPU acceleration setting too.

1 Like

You can manually adjust clocks and maybe power draw too, but seriously 55 degrees celsius is fine. Look at nvidia-smi.

1 Like

Thanks for the reply guys,

I don’t mind the GPU being at 50 degrees if that’s how Linux works (even though on Windows it was max 40 when idle) but the fans kick in too heavily.
It’s like the graphic card keeps rising in temperature and then the coolers kick in making an annoying noise and it keeps doing this with short interruptions for like 2-4 seconds.

Perhaps the question should be formulated like this: is there a way to have the fans gradually cooling the GPU without a lot of noise? :pray:

I think it’s just a thing with Nvidia GPUs on Linux, my 3080 Ti does the same but I don’t mind the fan noise.
Maybe try to set a fan profile with GreenWithEnvy:

I activated the Firefox one. Can’t say there is an improvement though.
I did play with VLC. I tried multiple combinations of settings options in preferences for video, audio and input/codec. I also tried between pulse-audio server and pipewire server (as the videos have slight stuttering to audio/video sync with a short interruption of the audio when the video starts or when you skip by using the seekbar.
Unfortunately… it’s the same…

Also installed this but… it doesn’t have many options or buttons… seems to be more like an information center, do you have any steps for how to do it?

To troubleshoot the video issue I would try to unplug one monitor to see if this is better.
Also you can try to check the Force full composition pipeline option in the Nvidia X Server Settings.

To set a fan profile in GreenWithEnvy you have to enable Nvidia Coolbits in your xorg.conf file under /etc/X11
(if it does not exist run sudo nvidia-xconfig)

Add the line Option “Coolbits” “12” under the device section, it should look like this:

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "NVIDIA GeForce RTX 3080 Ti"
    Option         "Coolbits" "12"

Reboot your system and now you can set a custom fan profile in GWE.
(For me it takes about 30s for the fans to change speed after I click Apply)