Nvidia-installer not working

i tried to install nvidia drivers using the install script. after the first reboot when i try to run nvidia-settings i get this error ERROR: NVIDIA driver is not loaded
ERROR: Unable to load info from any available system.

im assuming this means nouveau is still loaded? ive tried blacklisting it but that does fix it. ive also removed nvidia and gone back to nouveau and reinstalled that also is not fixing it. what am i doing wrong?

1 Like

Enter from a terminal window
ls -l /proc/driver
This should list drivers currently in use.

I assume you used install-nvidia-dkms to install the drivers, after you rebooted from the ISO installer. That is the preferred way to accomplish installing Nvidia drivers.

If on the small chance you are running nvidia-install-dkms while still in the ISO environment, that will not accomplish what you looking for.

the /proc stands for processor in directory /proc
The /proc directory has all kinds of information on your system
to name a few.
If it is a file, such as cpuinfo just
cat /proc/cpuinfo
to view your cpu information
if it is a directory such as /proc/driver
ls -l /proc/driver
will list the files/directories for drivers. The drivers listed could be files or directories, cd into the appropriate driver’s directory for more in depth info

Check /proc out if you haven’t done so previously.


You might want to try this:

For nouveau
First, not many realize (including me until a couple of days ago) that nouveau has two components. The nouveau kernel module, and the xorg-video-nouveau xorg driver.
1 Remove any Nvidia drivers that may be installed.
2 Install nouveau drivers. pacman -S xorg-video-nouveau
3 edit /etc/gdm/custom.conf
find the line #WaylandEnable=false it should be commented out (prefaced by #) if not add the leading # to comment it out
4 edit /etc/mkinitcpio.conf
find the line MODULES=’" " edit it to MODULES=“nouveau”
5 mkintcpio -p linux
6 reboot
At the GDM login password entry screen, click on the options gear. You should see
GNOME Classic
GNOME on Xorg
choose you poison, GNOME and GNOME Classic with be on Wayland, it’s obvious what GNOME on Xorg is.
After log-in, in a terminal window enter
You will get either wayland or x11 depending on your choice.

For Nvidia drivers
1 install drivers with nvidia-installer-dkms
2 edit /etc/gdm/custom.conf
find the line #WaylandEnable=false it may or may not be commented out (prefaced by #) if it is commented out, remove the leading # to uncomment it
3 edit /etc/mkinitcpio.conf
find the line MODULES=’" " edit it to MODULES=“nvidia”
4 mkinitcpio -p linux
5 reboot
At the GDM login password entry screen, click on the options gear. You should see
GNOME Classic
Both of these choices will be on Xorg. I have not yet been able to use Nvidia drivers on Wayland.
After log-in, in a terminal window enter
You will get x11.

At this point I haven’t gotten the Wayland option to work with Nvidia, so it’s
nouveau + Wayland
Nvidia + xorg


by nvidia-installer you are talking about our script or the one from Nvidia itself?

what you should do exactly??

nvidia-installer-dkms -t

to test and then run real install with:

sudo nvidia-installer-dkms

see here:


at first i wasn’t installing the dkms version. i am using the nvidia-installer script. i did install the dkms and am still getting the same error. when i did the reboot after installing dkms version i got an error about nouveau stalling at fffffff. i still have the opinion that somehow either the script is bad or something with my system is not blacklisting nouveau.

the basic symptom is the nvidia driver is not being loaded by the system. also forgot to mention i have a optimus system.

do you run test install? ( -t option)
do you use -b option to install bumblebee and configuration?

-b, --bumblebee For Nvidia Optimus cards (Bumblebee + proprietary Nvidia drivers)

Test run is always the first run you should do as the output will tell you if there is an issue!

i did test it seemed to run fine. and i did use the -b option.

lspci > log.txt && lsusb >> log.txt && journalctl -b -0 >> log.txt && cat log.txt | curl -F 'f:1=<-' ix.io

will give us boot log and system info to see what is going wrong then :wink:


doing some more digging around and i see the nvidia driver isn’t even being installed.

00:02.0 VGA compatible controller: Intel Corporation UHD Graphics 620 (rev 07)
02:00.0 3D controller: NVIDIA Corporation GP108M [GeForce MX150] (rev ff)

what gives you?

lspci -vnn | grep '\''[030[02]\]'

i do not see any nvidia or nouveau and no bumblebee stuff running from your log…

00:02.0 VGA compatible controller [0300]: Intel Corporation UHD Graphics 620 [8086:5917] (rev 07) (prog-if 00 [VGA controller])
02:00.0 3D controller [0302]: NVIDIA Corporation GP108M [GeForce MX150] [10de:1d10] (rev a1

i don’t see it in /dev either. i don’t get whats going on i know i have a nvidia card.

there are two types of optimus notebooks… some are have an option to handle it in bios others do not have this…
If your BIOS is controlling optimus settings you need to do this:

Disable Optimus

After the installation has completed reboot your system, and enter the BIOS configuration utility. Most Nvidia Optimus cards run alongside Intel integrated graphics. Find your display settings, and select “Intel Integrated”, or something similar - just make sure that Optimus and Discrete are not enabled. Also, make sure that the setting below it, “Detection by OS” setting is disabled.

You should also check what is installed:

pacman -Qs nvidia
pacman -Qs bumblebee