Nvidia-inst on arch

Hey guys,
I’ve a laptop where I’ve installed directly arch instead of EnOS and as in the title, is possible to use nvidia-inst to install nvidia driver on that?

I think it should work as well, although I haven’t tried that lately.

But you may need some dependencies from EndeavourOS repo…
Looks like variable EOS_ROOTER might be the only thing that’s needed.
That could be replaced by:
sudo bash -c

mm, I tried before your edit and this is what the terminal returns

/usr/bin/nvidia-inst: line 573: /usr/share/endeavouros/scripts/eos-script-lib-yad: No such file or directory

Yeah, that’s the bash lib file from package eos-bash-shared which is source’d.
You could comment out that and try again to see if there are any other missing stuff.
Or create an empty (or one with the EOS_ROOTER definition) file in the same location.

worked without errors, but seems to have done nothing, rebooted and if I grep Nvidia the shell return nothing

It should show what it is doing. If you already have the needed packages installed, it will no nothing.

It was designed to work in the EndeavourOS environment (which is not far away from Arch). So if it is not working on Arch, it needs debugging with bashdb
If you are willing to do that and find the problem spot(s), it would be greatly appreciated. :sweat_smile:

ok so, apparently my nvidia card is turned off and arch doesn’t turn it on (impossible to go from D3Cold to D0 state).
I’ll investigate this and if the script continue to not work debug it and let you know!

EDIT: tested with the card fixed and nvidia-inst and it work without problem. So only the two modification previously added are needed.

Thanks for the help.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.