NVIDIA GPU not using correct driver (llvmpipe)

Hi, I’m fairly new to EndeavourOS and lightweight linux distributions in general.

When I first installed this OS games would run perfectly fine and my GPU was using the correct NVIDIA driver. However a couple days ago I changed my screen resolution using ARandR, saved it, and since then I’ve struggled to get my GTX 1060 to NOT use the llvmpipe driver. I’m using Minecraft as a reference since it shows the GPU used in the F3 menu. When using the llvmpipe driver I get around 15 fps compared to 300+.

I’ve tried:

  • Deleting xorg.conf (this just makes my monitors default to 1024x768)
  • Regenerating xorg.conf (Correct resolution, but the same open source driver)
  • Running nvidia-xconfig (Doesn’t seem to do anything)
  • Adding the nvidia-drm.modeset=1 option into the GRUB boot options (I don’t understand what this does but I tried it anyway with no success)

Any help to get my GTX 1060 to use the correct NVIDIA drivers would be greatly appreciated, thanks!

Hello @jaffa
I also have a GTX 1060 6 GB card. Are you able to post the output of this command.

inxi -Faz --no-host | eos-sendlog

Edit: You need to set ALL of the additional enhancements for your Nvidia card as per the wiki. You can set up the hook at the bottom of the wiki page or just install the nvidia-hook package instead but do all the other enhancements on the page along with it. This will ensure your card is loaded properly and you won’t have any more issues. Anything you don’t understand just ask.

1 Like

Thanks! I followed all the steps on the wiki page and after a reboot the correct drivers are being used.

It’s easy to check. What i do is install the following.

yay -S mesa-demos
yay -S xorg-xdpyinfo

Then run inxi -Ga and it should show you exactly what you need to see. This is just another thing that helps to see the card, the driver, xorg and that the module has loaded properly for the graphics card.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.