Nvidia GPU cannot be used in Wayland sessions

I have a hybrid GPU laptop with 11th Gen Intel and Nvidia MX350. Everything works perfect on X11. but when i try Wayland, the Nvidia GPU aren’t being used, even though i set it as primary GPU with envycontrol it keeps using the Intel one. It’s there, detected but not used.

Operating System: EndeavourOS
KDE Plasma Version: 5.27.3
KDE Frameworks Version: 5.104.0
Qt Version: 5.15.8
Kernel Version: 6.2.8-arch1-1 (64-bit)
Graphics Platform: X11
Processors: 4 × 11th Gen Intel® Core™ i3-1115G4 @ 3.00GHz
Memory: 7.5 GiB of RAM
Graphics Processor: NVIDIA GeForce MX350/PCIe/SSE2
Manufacturer: LENOVO
Product Name: 82KA
System Version: Lenovo V14 G2 ITL


I’ve done that, same result

Are you on grub or systemd boot? (grub here).

Per @dalto :

You don’t edit the entries. You edit /etc/kernel/cmdline

Then run sudo reinstall-kernels to apply the change.

The entries are dynamically generated so they change.

This is also described in the wiki article.

I have a relatively old install, with grub, but I did swap to dracut.


i’ll try it brb

/etc/kernel/cmdline output are

nvme_load=YES nowatchdog rw rootflags=subvol=/@ root=UUID=9ef5da68-1342-4895-988c-f80892eeb7f0 nvidia-drm.modeset=1

and i’ve done sudo reinstall-kernels and it still the same

Out of ideas. :frowning:

Just a thought - what packages for wayland have you installed? I have:

kwayland-integration 5.27.3-1 (plasma)
plasma-wayland-protocols 1.10.0-1
plasma-wayland-session 5.27.3-1

And what does inxi -G return, mine is:

  Device-1: NVIDIA GA104M [GeForce RTX 3070 Mobile / Max-Q] driver: nvidia
    v: 530.41.03
  Device-2: Bison Integrated Camera type: USB driver: uvcvideo
  Display: wayland server: X.Org v: 23.1 with: Xwayland v: 23.1.0
    compositor: kwin_wayland driver: X: loaded: nvidia unloaded: modesetting
    gpu: nvidia,nvidia-nvswitch resolution: 1920x1080~144Hz
  API: OpenGL v: 4.6.0 NVIDIA 530.41.03 renderer: NVIDIA GeForce RTX 3070
    Laptop GPU/PCIe/SSE2
  Device-1: Intel Tiger Lake-LP GT2 [UHD Graphics G4] driver: i915 v: kernel
  Device-2: NVIDIA GP107M [GeForce MX350] driver: nvidia v: 530.41.03
  Device-3: Chicony Integrated Camera type: USB driver: uvcvideo
  Display: wayland server: X.org v: with: Xwayland v: 23.1.0
    compositor: kwin_wayland driver: X: loaded: modesetting,nvidia dri: iris
    gpu: i915,nvidia resolution: 1518x853
  API: OpenGL v: 4.6 Mesa 23.0.1 renderer: Mesa Intel UHD Graphics (TGL GT2)


pacman -Qs plasma | grep -i wayland 
local/kwayland-integration 5.27.3-1 (plasma)
    Provides integration plugins for various KDE frameworks for the wayland windowing system
    Qt component to allow applications to make use of the Wayland wl-layer-shell protocol
local/plasma-wayland-protocols 1.10.0-1
    Plasma Specific Protocols for Wayland
local/plasma-wayland-session 5.27.3-1
    Plasma Wayland session

To enable support for Wayland in Plasma, also install the plasma-wayland-session package. If you are an NVIDIA user, also install egl-wayland if it is not already installed, and if the session does not start with the proprietary nvidia driver, also enable the DRM kernel mode setting.

:eye: https://wiki.archlinux.org/title/Plasma#Plasma

Try installing egl-wayland and see if that will resolve the issue.

Yes i have egl-wayland installed before

It doesn’t show in the output you posted on the installed wayland packages on your system.

The command I shared will only show plasma. egl is not plasma-specific.

1 Like

What application do you use to switch between GPU modes?

I use the BIOS, Lenovo Legion 5 AMD/nVidia.

i wonder if envycontrol only works in X11 and not in wayland

Exactly. Don’t make your life tougher than it needs to be.

I need the Wayland fractional scaling feature, but not desperately
Guess i’ll just wait