Nvidia drivers broken after update

Hello there,
yesterday I updated my system, when I rebooted it, I’m stuck on “Reached target Graphical Interface”.
I used ctrl+alt+F2 to open a terminal and I tried to reinstall nvidia driveres but I’ve probalby failed because I can’t see any improvement. The command I wrote is: yay -Syu --needed nvidia-470xx-dkms nvidia-470xx-utils nvidia-470xx-settings

I attach the result of inxi -Ga:

The version of the driver is outdated.
The version of nvidia-470xx-dkms should be 470.182.03-1.

You could try this:


and if that doesn’t help, try

yay -S nvidia-470xx-dkms nvidia-470xx-utils nvidia-470xx-settings

And if that doesn’t help, we need some logs. For example:

cat /var/log/Xorg.0.log | eos-sendlog

and post the URL here.

Yay did nothing because it was already updated.
Instead I saw that the second command was installing 470.182.03, but after rebooting the problem is still present… I checked inxi -Ga and it still show 470.161.03… Honestly I don’t know why…

The URL is: https://0x0.st/HXiW.txt

For some reason url with the log is not opening for me at the moment but anyway…

I have similar GPU (mobile version). In case you use dracut and don’t have nvidia-hook package, you might find this thread I created several days ago helpful.


Thank you!!!
Running sudo dracut-rebuild and then yay -S nvidia-470xx-dkms nvidia-470xx-utils nvidia-470xx-settings solved my problem!

Thanks for your support :grin:

1 Like

Glad to hear that!

Just one note: the order should be reverse. You have to rebuild your init images after updating or installing nvidia driver (in case you don’t have latest nvidia-hook package installed, otherwise it’ll be handled by hook automatically during such process)

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.