Nvidia Drivers automatically disable Wayland

I recently switched from Fedora35 (GNOME+Wayland) to EndeavourOS on a laptop with Hybrid Graphics (intel i7 + Nvidia RTX 3050) but I can’t manage to install the nvidia drivers correctly.

At first I tried to install the drivers using the nvidia-inst package (that should be the successor of nvidia-installer-dkms, shouldn’t it?), but maybe I installed too many packages (for example I discovered just later that with wayland I can’t use something like optimus-switch) that were conflicting because in the end I wasn’t able to run an application using the Discrete GPU (prime-run <application> didn’t worked and there was no right-click option altough switcheroo-control was up and running)

So I tried to follow the EndeavourOS blog posts about installing nvidia drivers and, after deleting all the nvidia-related packages I previously installed, I did a second attempt using sudo nvidia-installer-dkms. This (apparently) installed the driver correctly but magically switched my WM to X11 and, even following the additional steps provided in the EndeavourOS post, I wasn’t able to use Wayland again (untill I reverted to Nouveau drivers, then Wayland came back magically).

So, anyone has had my same problem? How did you solve it?
It’s realy annoying having to stick with Nouveau drivers (some programs like Davinci Resolve don’t even work properly with them) and, since with Fedora everything was working properly, if I don’t manage to solve this I’ll probably switch to another distro :frowning:

Since Wayland on nvidia was successful on Fedora, I don’t see why they won’t work fine on EnOS.
I don’t know much about EnOS utilities, although other users would.
But without any technical info and logs (as described at EnOS wiki, if you had some time to review), we cannot do any successful guess. :person_shrugging:

My question was more to see if someone encountered my same problem while installing nvidia drivers on Endeavour (I hope I’m not the only one with an nvidia gpu that wants to use Wayland).
If you need extra information or logs to help me just tell me what do you need and I’ll update the post

Is there a little gear icon at the bottom right?
If not you can try this

  • Workaround Create a file in /etc/modprobe.d/nvidia-power-management.conf containing the text:
options nvidia NVreg_PreserveVideoMemoryAllocations=1

from https://askubuntu.com/questions/1403854/cant-use-wayland-with-nvidia-510-drivers-on-ubuntu-22-04-lts

and see if Wayland option is present again.

For prime-run, it should work out of box. Did you try any other application besides Firefox?


Check out this Arch Linux discussion I saw from the other day that might help you out, the top comment is one solution worth looking into for you perhaps:

1 Like