Nvidia driver

Hi there…
Apologies if its a repeated question, i tried to find answer for my doubt… but i am not able to find it, also not sure if I am doing it correctly.
Is the graphics card driver installed in my machine ? Because a couple of times my desktop freezes and i did a force shutdown. Don’t know if it is because of the graphic card or software issue.

And below is the result for “inxi -G”
[vicky@vicky-dsktp ~]$ inxi -G
Device-1: NVIDIA GK208B [GeForce GT 710] driver: nouveau v: kernel
Display: x11 server: X.Org v: 21.1.4 driver: X: loaded: modesetting
dri: nouveau gpu: nouveau resolution: 1920x1080~60Hz
API: OpenGL v: 4.3 Mesa 22.2.3 renderer: NV106

Please let me know if its properly installed and how to find the root cause for the system freeze.

Thank you !

It has nouveau open source driver installed. The GT 710 series is not supported by current nvidia drivers.
You would have to install the 470.xx version from the AUR. To verify which drivers support this card you can run this and post the output.


Edit: If your card is supported by the 470 drivers you can use yay to install the packages.

yay -S nvidia-470xx-dkms

Also in the AUR if needed are the following packages that can be installed with yay.


Edit2: If you end up installing the nvidia drivers and reboot you could post the output of

inxi -Ga
1 Like

Hi @ricklinux
I am getting command not found error while running the command.

[vicky@vicky-dsktp ~]$ nvidia-driver-supported-branches
bash: nvidia-driver-supported-branches: command not found

Okay maybe some package needs to be installed in order for that to be run. :thinking: Let me check the wiki page.

Edit: I think you need to install this package first and then run the command.

sudo pacman -S nvidia-inst


Edit: I’m pretty sure your card is supported by the 470xx version as i checked on the Nvidia website anyway. But this is a tool that we use to check the data base.

Yeah… now able to execute the command.
[vicky@vicky-dsktp ~]$ nvidia-driver-supported-branches
lspci: Unable to load libkmod resources: error -2
NVIDIA card id: 128b
Fetching driver data from nvidia.com

Series 470: supported (nvidia.com: 470.141.03)

Okay so you should be able to install the nvidia-470xx-dkms version from the AUR.

I am assuming this is a desktop computer?

Yes… its desktop computer

You can install those drivers from the AUR using yay with the command i posted above. If you are not familiar with the package build used by yay it asks questions. Just press enter for each but you can read the questions first so you get familiar with the process.

Edit: I hope I’m being helpful?

You were so helpful :slight_smile:
I have installed those as per your commands. Below is the output for inxi -Ga

Excellent. There is also the settings package and utils package in the AUR for the 470xx version drivers if you need them for any reason. Now you can see if the freezing stops.

I can’t read the whole post. Looks like the image might be on top of some text. You can edit it and move the image down a bit?

What desktop do you have installed?

I just copy pasted the content from the terminal.

[vicky@vicky-dsktp ~]$ inxi -Ga
  Device-1: NVIDIA GK208B [GeForce GT 710] vendor: ASUSTeK driver: nvidia
    v: 470.141.03 alternate: nouveau,nvidia_drm non-free: series: 470.xx+
    status: legacy-active (EOL~2023/24) arch: Fermi 2 code: GF119/GK208
    process: TSMC 28nm built: 2010-16 pcie: gen: 2 speed: 5 GT/s lanes: 8
    bus-ID: 01:00.0 chip-ID: 10de:128b class-ID: 0300
  Display: x11 server: X.Org v: 21.1.4 compositor: xfwm v: 4.16.1
    driver: N/A display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x286mm (20.00x11.26")
    s-diag: 583mm (22.95")
  Monitor-1: HDMI-0 res: 1920x1080 hz: 60 dpi: 102
    size: 477x268mm (18.78x10.55") diag: 547mm (21.54") modes: N/A
  API: OpenGL v: 4.6.0 NVIDIA 470.141.03 renderer: NVIDIA GeForce GT
    710/PCIe/SSE2 direct render: Yes
[vicky@vicky-dsktp ~]$

The image looks like it’s on top of this output. But that’s okay. Usually when you post output like this above you use code tags around your output. So you can put three back ticks ``` before and after the output you post or use three tilde ~~~ before and after what you post. I’m referring to the post above.

Edit: Hope this makes sense? You can edit the above post and add those if you like so you see what i mean. Then it will look like this.

[ricklinux@eos-kde ~]$ inxi -Ga
  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
    vendor: Gigabyte driver: amdgpu v: kernel arch: GCN-4 code: Arctic Islands
    process: GF 14nm built: 2016-20 pcie: gen: 1 speed: 2.5 GT/s lanes: 16
    link-max: gen: 3 speed: 8 GT/s ports: active: HDMI-A-1 empty: DP-1, DP-2,
    DP-3, DVI-D-1 bus-ID: 2d:00.0 chip-ID: 1002:67df class-ID: 0300
    temp: 48.0 C
  Display: x11 server: X.Org v: 21.1.4 compositor: kwin_x11 driver: X:
    loaded: amdgpu unloaded: modesetting alternate: fbdev,vesa dri: radeonsi
    gpu: amdgpu display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: HDMI-A-1 mapped: HDMI-A-0 model: Samsung S24D330
    serial: 1515869238 built: 2019 res: 1920x1080 hz: 60 dpi: 92 gamma: 1.2
    size: 531x299mm (20.91x11.77") diag: 609mm (24") ratio: 16:9 modes:
    max: 1920x1080 min: 720x400
  API: OpenGL v: 4.6 Mesa 22.2.3 renderer: AMD Radeon RX 590 Series
    (polaris10 LLVM 14.0.6 DRM 3.48 6.0.11-arch1-1) direct render: Yes
[ricklinux@eos-kde ~]$ 

Yes… i have updated like you said… now the post is readable :slight_smile:

Excellent. So there are three ways you can do this. Use the pre-formatted text button in the menu or the three back ticks or three tilde.

Not sure what desktop you have installed?

I might be mistaken, but are you referring to the Desktop environment? If so, the screenshot in his post says it’s xfce 4.16

I wasn’t looking just asking the OP. Sometimes I don’t always notice these things. :wink:

1 Like