Nvidia driver problems

So after rebooting my pc after installing the nvidia drivers it gets stuck at “ [. OK. ] Finished update boot loader random seed “ I searched around and couldn’t find how to I’m really new to Linux and this is my first time running Linux on my main pc so yeah how do I fix this p.s i don’t know how to get error logs and such

Hi and welcome!

Here some infos how to provide error logs and system infos

Post at least a link to your hardware info to begin with inxi -Fxxc0z | eos-sendlog


If you know nothing about Linux, arch based distros and Nvidia graphics are probably a difficult place to start with.

If you are patient enough and willing to learn you might be able to fix it. If not there are easier alternatives like pop OS where things like that generally work our of the box.

What’s your Nvidia card? One way to fix it could be to log in the Konsole via TTY, then update your system, install Nvidia drivers and or provide proper logs here. If you can’t access, an alternative is to chroot into Arch using the install USB and fix things there.

  • here how to get into TTY, press Alt+F1


  • here how to install nvidia depending on your kernel and card. Looks like the eos team added e new installer. I haven’t use that one yet…


Can you walk us through exactly what you did? Else it’s finding a needle in a haystack…

The system specs are rtx 3080 cpu i9 13900k and motherboard Msi pro z69o a

And exactly what I did was that after installing endeavor I opened the terminal and logged into root with su and then I ran pacman -S nvidia and after installing that I rebooted and then after That it got stuck on the ok

you need to add
ibt=off on boot kernel

new iso should add for 12 & 13 gen intel if there is a nvidia card


How do I turn ibt to off

Which kernel did you install? You need the right driver for the right card, and also for the right kernel…

Normally nvidia-dkms and nvidia-headers need to be installed both and took care of that. As mentioned above eos team seems to have changed something recently. I will defer to @joekamprad

on update pacman , LTS is now 6.1.12 kernel no more 5.15 LTS series

1 Like

I installed 6.1.12-arch1-1

since you have lts you may want to install the nvidia-lts version and remove nvidia package.

sudo pacman -Rs nvidia

Or install the nvidia-dkms which should also work with other kernels to my understanding. I also commonly install nvidia-settings.

sudo pacman -S nvidia-dkms nvidia-settings

If nvidia-dkms doesn’t boot:

Ok follow @Stephane advice which is also mentioned in the arch wiki, the purple box with a note here:


Edit: hope I didn’t get things wrong with the packages, it’s been a while I have used Nvidia. nvidia is for mainline kernel and nvidia-lts for lts kernel. nvidia-dkms works for both

Edit2: essentially steps 1, 3 and 4 here Problem with nvidia-installer-dkms on hybrid graphics booting to black screen

so this is not a notebook… (no optimus hybrid GPU)
and recommended is to use nvidia-inst to install nvidia drivers…
to test first run:
nvidia-inst -t
(this will only emulate what it would do and give logs to check if it would run fine)
if no errors show up… run it for real:
This will install nvidia-dkms package and all other needed packages plus sets needed kernel parameter (DRM modesetting) ibt=off must be set manually (afaik) see here how to do that for systemd-boot or grub:

edit /etc/kernel/cmdline:
(needs to be edited as admin/root)
sudo nano /etc/kernel/cmdline p.e.
after this rebuild kernel images to include the changes:
sudo reinstall-kernels

edit /etc/default/grub:

save the file and regenerate grub.cfg:
sudo grub-mkconfig -o /boot/grub/grub.cfg

1 Like

Just bookmarked this one… Thank you. Although I don’t plan on getting Nvidia laptop in the future.

yes better not need this :wink: i should may add it to wiki on some place.
But the Archwiki article for Nvidia is the best and deepest info you can get about it indeed…

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.