Nvidia driver issue

Greetings to the forum. I just installed EndevourOS but without the proprietary nVidia drivers for my GEForce GTS450 card. I have 2 monitors and using the settings I set “mirror screens” and everything is fine. Unfortunately I don’t understand how to install the nvidia proprietary drivers, as it happens that after the stop command the os. lists a series of operations up to the stop sign but remains in operation (it is as if it could not release the graphic part).
I ask for the help of the forum. (I don’t want to reinstall the os)
Thank you
Below is the system info

[apanta@apanta-tobefilledbyoem ~]$ nvidia-inst -t
bash: nvidia-inst: comando non trovato
[apanta@apanta-tobefilledbyoem ~]$ nvidia-inst
bash: nvidia-inst: comando non trovato
[apanta@apanta-tobefilledbyoem ~]$ inxi -Ga
  Device-1: NVIDIA GF106 [GeForce GTS 450] driver: nouveau v: kernel non-free:
    series: 390.xx+ status: legacy-active (EOL~late 2022) arch: Fermi
    code: GF1xx process: 40/28nm built: 2010-16 pcie: gen: 1 speed: 2.5 GT/s
   Display: x11 server: X.Org v: 21.1.7 compositor: xfwm v: 4.18.0 driver: X:
    loaded: modesetting alternate: fbdev,nouveau,nv,vesa dri: nouveau
    gpu: nouveau display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1280x1024 s-dpi: 96 s-size: 339x271mm (13.35x10.67")
    s-diag: 434mm (17.09")
  Monitor-1: HDMI-A-1 mapped: HDMI-1 pos: primary model: LG (GoldStar) TV
    serial: 16843009 built: 2011 res: 1280x1024 hz: 60 dpi: 203 gamma: 1.2
    size: 160x90mm (6.3x3.54") diag: 184mm (7.2") ratio: 16:9 modes:
    max: 1920x1080 min: 720x400
  Monitor-2: VGA-1 pos: primary model: LG (GoldStar) L1918S serial: 100363
    built: 2007 res: 1280x1024 hz: 60 dpi: 86 gamma: 1.2
    size: 376x301mm (14.8x11.85") diag: 482mm (19") ratio: 5:4 modes:
    max: 1280x1024 min: 720x400
  API: OpenGL v: 4.3 Mesa 22.3.4 renderer: NVC3 direct-render: Yes
[apanta@apanta-tobefilledbyoem ~]$ 
[apanta@apanta-tobefilledbyoem ~]$ inxi -FZA
  Host: apanta-tobefilledbyoem Kernel: 6.1.10-arch1-1 arch: x86_64 bits: 64
    Desktop: Xfce v: 4.18.1 Distro: EndeavourOS
  Type: Desktop Mobo: ASRock model: K10N78FullHD-hSLI..
    serial: <superuser required> BIOS: American Megatrends v: P2.30
    date: 04/30/2010
  Info: dual core model: AMD Athlon 64 X2 5200+ bits: 64 type: MCP cache:
    L2: 1024 KiB
  Speed (MHz): avg: 1000 min/max: 1000/2700 cores: 1: 1000 2: 1000
  Device-1: NVIDIA GF106 [GeForce GTS 450] driver: nouveau v: kernel
  Device-2: Logitech Webcam C310 type: USB driver: snd-usb-audio,uvcvideo
  Display: x11 server: X.Org v: 21.1.7 driver: X: loaded: modesetting
    dri: nouveau gpu: nouveau resolution: 1: 1280x1024~60Hz 2: 1280x1024~60Hz
  API: OpenGL v: 4.3 Mesa 22.3.4 renderer: NVC3
  Device-1: NVIDIA MCP72XE/MCP72P/MCP78U/MCP78S High Definition Audio
    driver: snd_hda_intel
  Device-2: NVIDIA GF106 High Definition Audio driver: snd_hda_intel
  Device-3: Logitech Webcam C310 type: USB driver: snd-usb-audio,uvcvideo
  Device-4: TerraTec GmbH Aureon Dual USB type: USB
    driver: hid-generic,snd-usb-audio,usbhid
  Sound API: ALSA v: k6.1.10-arch1-1 running: yes
  Sound Server-1: PipeWire v: 0.3.65 running: yes
  Device-1: NVIDIA MCP77 Ethernet driver: forcedeth
  IF: enp0s10 state: down mac: 00:19:66:95:bb:3a
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    driver: r8169
  IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: 50:3e:aa:0d:94:6e
  Local Storage: total: 4.32 TiB used: 6.89 GiB (0.2%)
  ID-1: /dev/sda vendor: Samsung model: SSD 850 EVO 500GB size: 465.76 GiB
  ID-2: /dev/sdb vendor: Seagate model: ST2000DM001-1ER164 size: 1.82 TiB
  ID-3: /dev/sdc vendor: Seagate model: ST31000528AS size: 931.51 GiB
  ID-4: /dev/sdd vendor: Crucial model: CT250MX500SSD1 size: 232.89 GiB
  ID-5: /dev/sde vendor: Crucial model: CT1000BX500SSD1 size: 931.51 GiB
  ID-1: / size: 40.64 GiB used: 6.89 GiB (17.0%) fs: ext4 dev: /dev/sdb3
  Alert: No swap data was found.
  System Temperatures: cpu: 32.0 C mobo: N/A gpu: nouveau temp: 35.0 C
  Fan Speeds (RPM): N/A gpu: nouveau fan: 0
  Processes: 171 Uptime: 27m Memory: 7.76 GiB used: 1.7 GiB (21.9%)
  Shell: Bash inxi: 3.3.25
[apanta@apanta-tobefilledbyoem ~]$ A

You may need to install the package nvidia-inst first

yay -S nvidia-inst

Then run the installer.



Try this !

Just open yay in your terminal

type : yay nvidia ( now you will get a list all nvidia related ) and pick the driver , settings ultils you need.

for example number 2 , then you will be installing : 2 endeavouros/nvidia-inst 1.12-1 (19.3 KiB 21.6 KiB)
Script to setup nvidia drivers (dkms version) in EndeavourOS.

As what i can see you have a 460 Card so that means you can also install the 430 dkms package, utils,settings.
But you can also try the 470 those are newer

This is a Fermi generation, which is stack at nvidia 390. These drivers are not recommended anymore, as development has stopped a long time ago and there are issues, even if you install them from AUR.

Open Source nouveau is recommended (which is included in the kernel, and already installed/working on your system).

1 Like

Thanks for the replies.
I installed nvidia-inst and gave the command to find drivers. The recommended driver is:
[apanta@apanta-tobefilledbyoem ~]$ nvidia-inst --driver
Nvidia card ID: 0dc4
Fetching driver data from nvidia.com
Series 390: supported (nvidia.com: 390.157)
[apanta@apanta-tobefilledbyoem ~]$
What is the command to install this driver?
Thanks in advance
I want to install the proprietary drivers because the system won’t shut down (it doesn’t seem to be able to detach from the graphics environment managed by the nouveau drivers)
Driver 390.157 works fine on ubuntu 22.04, MX-Linux 19.4, Ubuntu 20.04 and PCLinuxOS as well.

I don’t think that driver is maintained currently. We have had reports of it no longer being compatible with the current kernel.

If you want to try to use it anyway, first switch to the LTS kernel.

Thanks. how can i setup the lts kernel

If this problem is what makes you think it is caused by the video card, I think we are dealing with an xy-problem.

As already explained, using nvidia390 is a rough road to take, unless you are experienced enough on Linux, or you have no concern troubleshooting future video related issues.

I highly suggest you troubleshoot your original issue (shutting down the system properly) first.
But the decision is always yours. :wink:

1 Like

Thanks a lot.
You are right. In fact now, starting the s.o. after the list of operations, the screen remains black with intermittent flashes, as if it wants to load the GUI but cannot do it. therefore the system is currently inaccessible.
I would like to try reinstalling from usb, initially choosing to use the proprietary drivers. suggestions?
(p.s.: I’m writing from ubuntu 22.04 where I had the same initial problem and then solved via terminal, installing the nvidia drivers)

1 Like

The installer can only install the most recent drivers. It can’t install the older unsupported drivers.

Those drivers are no longer available in the repos.

1 Like

Things get complicated. now the upload of the live stops after the welcome and a flashing cursor appears.
After several attempts (Ctrl+Alt+F2) it appears:
How can I continue?

You can login there with your username and password.

If you installed the 390x drivers without switching to the LTS kernel, that would be the expected behaviour which I warned you about above.

If that is the ISO, you need to choose the open source option. The nvidia option won’t work with your hardware.

Maybe I didn’t explain well.
The writing tty appears while loading the live usb.
Too many problems surely caused by my inexperience.
I think I have to leave EndevouOS and switch to other OS.
Thanks anyway for the help

It was understood.
Did you select Open Source drivers?

Yes, I chose Open source drivers and it crashes exactly at the same loading point as the live.
I also downloaded a new ISO and prepared another live usb, but it stops at the same point as well.
would like to be able to install the s.o. in another partition on a separate disk. but I can’t upload the live anymore :worried:

This doesn’t make any sense to me. You boot on the live ISO and you can select latest nvidia cards or the default entry. If it boots on the default entry it should still install with nouveau open source drivers. If you boot on latest nvidia card and it boots it will install with nvidia drivers if your card supports them.

Edit: If it installed then you just need to install drivers that support the card which are 390.xx version
As far as i know they are still listed in the AUR

yay -S nvidia-390xx-dkms

Thanks, I’ll try and let you know

I’m sorry but I decided to switch to Ubuntu Budgie lts, since I couldn’t solve the problem (with nouveau the screen flickers).
Already installed Budgie lts with nvidia proprietary driver and then verified after installation (390.157). Thanks for the support and see you, hopefully, maybe in the near future

That’s unfortunate. You could have solved it here with 390.xx drivers

1 Like