Nvidia driver issue - MSI GP66 Nvidia RTX 3070 TI

Hi all,

I read a ton of documents online about this and I still cant figure it out. Seems Im an isolated case. I booted my laptop (MSI GP66 nvidia 3070) with the nvidia option and I get a graphical desktop.

However, nvidia-smi just hangs.

So I install anyway. When I get into XFCE, I do nvidia-smi again, nothing - just hangs.

lsmod only shows

$ lsmod |grep nvidia
nvidia              61218816  1

There should be much more here like DRI stuff and whatnot.

Here is the package thats installed

$ pacman -Qi nvidia
Name            : nvidia-dkms
Version         : 525.60.11-1
Description     : NVIDIA drivers - module sources
Architecture    : x86_64
URL             : http://www.nvidia.com/
Licenses        : custom
Groups          : None
Provides        : NVIDIA-MODULE  nvidia
Depends On      : dkms  nvidia-utils=525.60.11  libglvnd
Optional Deps   : None
Required By     : None
Optional For    : None
Conflicts With  : NVIDIA-MODULE  nvidia
Replaces        : None
Installed Size  : 68.44 MiB
Packager        : Sven-Hendrik Haase <svenstaro@gmail.com>
Build Date      : Tue 29 Nov 2022 07:57:14 AM MST
Install Date    : Fri 16 Dec 2022 01:33:54 PM MST
Install Reason  : Explicitly installed
Install Script  : No
Validated By    : Signature

Nothing in /etc/modprobe.d about nvidia - this is odd as I always see module options for nvidia

Also, kernel command line…

BOOT_IMAGE=/boot/vmlinuz-linux root=UUID=f07aa416-5b5d-4c31-b156-d5ef32b90b9d rw loglevel=3 nowatchdog nvme_load=YES nvidia-drm.modeset=1
$ lspci |grep -i vga
00:02.0 VGA compatible controller: Intel Corporation Alder Lake-HX GT1 [UHD Graphics 770] (rev 0c)
01:00.0 VGA compatible controller: NVIDIA Corporation GA104 [Geforce RTX 3070 Ti Laptop GPU] (rev a1)
System Information
	Manufacturer: Micro-Star International Co., Ltd.
	Product Name: Vector GP66HX 12UGS
	Version: REV:1.0
	Serial Number: K2207N0087106
	UUID: c3cd2324-deb2-b04e-a196-226960ff2f2b
	Wake-up Type: Power Switch
	SKU Number: 1545.3
	Family: GP

I do have a desktop, so it “Seems” like its working for at least Xorg, but doesnt seem like the drivers is working ?

As a side note… Fedora 37 runs fine on this laptop - I just like the Arch culture :slight_smile:

Thanks for any help!


As a side note, it looks like X is using the integrated card. So, I installed optimus-manager and did the switch, but it always resorts back to integrated.
I then tried to install Envycontrol and do that switch, then the laptop just locks up with a cursor in the upper left of the screen.

What is the processor? Intel? Do you have ibt=off as a kernel parameter in the default grub command line /etc/default/grub? Then update grub with sudo grub-mkconfig -o /boot/grub/grub.cfg

Yea Intel.

So… I booted off the live USB and put ibt=off and sure enough the nvidia modules loaded. So now I’m going to try and reinstall with that option and see what happens.

I’ll let you know how it works but so far so good!


1 Like

You can boot off the live USB that way but it’s not permanent. After the install you have to add it and update grub in order to keep it saved.

Edit: You shouldn’t need to reinstall. Just add it as i have said and update grub and reboot.

Thanks! I had to reinstall because I was testing other distros LOL… But, this worked!

So… sounds like this ibt thing is a bug fix for something supposedly coming in the 6.2 kernel?

Thanks again for the help with this… I was pulling out my hair LOL

1 Like

Welcome to the forum! :smile:

Please try command

nvidia-inst -t

(Note that you may need to install package nvidia-inst first.)

The command should give a message about parameter ibt=off.
The command does not change anything on your system because of option -t.

Pulling your hair out doesn’t help. It just makes a mess on the floor and you end up with a bald spot. :laughing:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.