[NVIDIA-DKMS-INSTALLER ISSUES SOLUTION] (Xorg based DE's)

Reddit member neezduts96 wrote:

Guys for all of those who use nvidia-installer-dkms facing issues with the proprietary nvidia drivers, just remove the 20-nvidia.conf by

sudo rm -rf /etc/X11/xorg.conf.d/20-nvidia.conf

And it should just work. It’s worked for me. Turns out it wasn’t an issue of the drivers or xorg.

NOTE: The dev team is working on a suitable solution, in the meantime, we have pinned this post and added the info on this wiki page:

Thank you Reddit member needzduts96 for notifying us and sharing the solution.

9 Likes

Hello, maybe I’m wrong, @Bryanpwo wrote that the issue is in Xorg based DE’s, but in the EndeavourOS Nvidia Installer entry in Discovery there is the issue about wayland DE’s. :thinking:

1 Like

You’re right! @joekamprad and @manuel can clarify?
(I don’t own Nvidia hardware)

1 Like

Not much to tell, but I have Nvidia GeForce 1030 card and use Xfce (so no wayland).

I had this mentioned file and my system worked as expected with it.
Then I removed the file, and the system kept working as expected.

So here, because the file is not needed, I’ll keep on going without it. :wink:

1 Like

I can clarify that only partly, as the post on Reddit is not clear about the underlying issue.

But it is indeed not only an issue for Xorg-based DEs. As it could be an issue for Optimus Notebooks independent from the used DE/WM.

And Wayland will use settings applied by X11. :wink:

1 Like

So, perhaps we can rephrase the line in our wiki article also, to avoid confusion?

BTW, it was also mentioned on the Arch forum:

https://bbs.archlinux.org/viewtopic.php?id=257889

1 Like

I do use /etc/X11/xorg.conf.d/20-nvidia.conf on Xorg session here too for enable ForceCompositionPipeline

I add some more info on the wiki entry…

2 Likes

It doesn’t write that file if it detects an optimus notebook.

I have an amd and nvidia card in my desktop with optimus installed. The only two files I have in /etc/X11/xorg.conf.d are:
00-keyboard.conf and 10-optimus-manager.conf

It also didn’t affect my desktop card GTX 1060 having the /etc/X11/xorg.conf.d/20-nvidia.conf but i have also removed it and makes no difference.

I do not see what exactly is the issue as the post on reddit does not give any details on that.
And the conf it writes should not do much anyways said from using nologo option what is not needed since a long time

From my reading the issue seems to be when you have both an active integrated gpu and an nvidia dedicated gpu on a desktop. That being said, I don’t currently have available hardware to test that.

That being said, this seems to be impacting a pretty small subset of users so perhaps we should unpin it?

I’m not totally sold on the fact that this is the underlying issue. We have no way of knowing exactly how those systems are set up & were configured. There have been a number of users who have had their systems working and others have struggles with getting them to work. Removing this file doesn’t seem to affect anything or having it for me. It is possible on some of these hybrid setups that they need some other xorg settings and this maybe conflicts with it? :man_shrugging: I don’t have any hybrid hardware and I’m no expert either.

This was my bet also… so more a BUG on something else… as it should not conflict if you have display plugged in to Nvidia pcie Card while the CPU have an unplugged igpu?
I see some reports from users with Optimus where it is a problem to have the nvidia config when it boots with intel enabled… and i am not sure if nvidia-installer-dkms pulls the file if you do not install bumblebee and only run it installing Nvidia drivers?

So, shall I unpin it?

I have a hybrid graphics nvidia laptop. I just installed nvidia and nvidia-dkms using pacman and had no issues at all. Optimus works. Using Cinnamon by the way.

this is not working ,
manjaro testing propose to downgrade on version 495-44

errors xorg login do not depends on file nvidia.conf , if it not exist on disk , it created in /var