Nvidia acting very strange when i install it

right okay so this is the fourth time i’ve had to reinstall my entire OS, for, a variety of reasons, i guess i’m just pretty good at messing them up, anyway i’ve had a lot of issues with stuff and one of those issues is that my computer, when it uses the AMD driver and not the NVIDIA one, makes games run REALLY slow, and also i can’t adjust the literal brightness on my computer. The fix, for the last few OS installs, is just to install nvidia, just, yay -S nvidia, and that about fixes everything. this time when i did this, for some accursed unknown reason, thats not what happens. the brightness, still not adjustable, is set to max basically blinding me, and even worse than that, it seems every time my computer wants to load files, from like a search or just scrolling down in a folder, or even just checking settings, flickers to black for about 1.4 seconds before coming back, which is cool when paired with the aformention MAX BRIGHTNESS, i think if i was epileptic, i would be dead by now
this would be, well not really manageable but i could cope with just, installing it when i want to play a game and uninstalling it after (and restarting ofc) if it actually then solved ANY of the remaining issues
theres a lot of other anomalies as well that i’ve noticed while trouble shooting

OpenEGL and OpenGLX exist, i dont think they usually have existed before, and also OpenEGL, is having an issue finding simpledrm.iso, as it doesn’t seem to exist. I have, in months of searching, not found a single way to obtain this file.

Xorg.conf, simply does not exist, the file is not there, its not present, and again, the ever so lovely search function will not bloody tell me how to install or get this file, how to put it there, it just doesnt exist

something somewhere said i might need ‘nvidia-installer-db’, i try yay -S nvidia-installer-db, there is no package

anyway if you need literally any info, just tell me HOW TO ACTUALLY GET THAT INFO and then i will post it, literally all of it, ive put off posting here for ages because people have a tendency to just say like
‘o post the djit.co logs’ and just, just say that, like, how would i know what that is or how to do that, just tell me the command, its like one extra sentence literally just SAY how to do it like thats basically spam to just not give me any sort of command or useful information

Using the hated N word will get you ignored by many around here!
But I am an Nvidia user myself and might be able to offer some help.

I’ll assume you have a modern nvidia GPU otherwise you’ll need to check if you do indeed need a legacy or other driver.

If you are using LTS release,
yay nvidia
if you are using the newest rolling release you need instead,
yay nvidia dkms
to change settings you need
yay nvidia-settings

Using the wrong nvidia driver can give you black screen.
In that case, CTRL+ALT+F3,
you can install from the TTY!
CTRL+ALT+F2 to get back to active session.

I have so many additional Nvidia packages I’m not sure what else to recommend at this point.
I believe just the driver, the nvidia settings and the default EOS packages related to nvidia are all you need to run stable though.

An important nuance: once installed, run nvidia-settings as root so you can save your changes.

If your gaming, you want proton glorious eggroll edition, this is essential imo for running windows games on EOS, runs seemly everything.

The brightness and related settings can be played around with in the nvidia settings.

You can also play around with kernels, ZEN kernel being slightly more performance able.

You can also change the default gamma using the terminal, see other sources for more info tho.

Nvidia is jank on linux because nvidia is jank to linux.
Support is improving all the time though.

Oh and finally, on your login screen, there is usually an option to choose wayland or Xorg.
pros and cons to both, the choice is yours.
Mine being Xorg.

okay so idk if you just didn’t read the post but i know all of this, the issue is i do all of this and then get the issues i mentioned above

btw i’m not like, beholden to NVIDIA, its just what i’ve used that makes stuff actually playable on my computer
if there’s a way to make games run properly and adjust my brightness WITHOUT switching to nvidia, i’d be THRILLED to know how

Find out the devicID and VendorID of the AMD gpu and than add those two your launch options of that game.

For example I use it for Diablo 4 because that specific game will for some reason pick the wrong integrated gpu in my desktop. So as an example I have this as my launch option in Steam for Diablo 4.
gamemoderun MESA_VK_DEVICE_SELECT=1002:744c! %command%

And this for when I launch it with Lutris under environment variables of that game.

I don’t use Proton GE but I do use WINE GE (in heroic) and it does run most of what I use it for I think the only 2 games I didn’t have it work with where Fallout 3 & NV

I’ve had a better experience with wayland but I see a lot of others say the opposite

You’re post is very unclear and hard to follow, I’m not having a go at you and I can read what you have written, it is just hard to understand


I think the high gamma and lack of brightness control mentioned above is related to a wayland session.

I also think I recall having to add a colour profile to it to gain some eye relief from it.

an easy way to check is inxi -G

Xorg brightness controls are still there.

Run the following in a terminal.
sudo pacman -S vulkan-mesa-layers

Then run the following command in a terminal.
MESA_VK_DEVICE_SELECT=list vulkaninfo

Output will look something like this.
selectable devices:

  GPU 0: 1002:744c "AMD Radeon RX 7900 XTX (RADV NAVI31)" discrete GPU 0000:03:00.0
  GPU 1: 1002:164e "AMD Radeon Graphics (RADV RAPHAEL_MENDOCINO)" integrated GPU 0000:0e:00.0
  GPU 2: 10005:0 "llvmpipe (LLVM 17.0.6, 256 bits)" CPU 0000:00:00.0

Save the VendorID and DeviceID of the gpu you want to use and add that to your launch options, my my case that would be these two.

Then add the following to launch options(Steam) or the environment variables(Lutris) of the game, replacing my example output with what you actually get.

Look at the top left hand corner of the page, see that thing that says Help? Look at its options. See where it says Wiki next to it also, full of useful guides.

No it’s not, learn to read your screen.

thx reading this post what does it have to do with my issue?? just sort of confused as it feels like this is a random gripe about nothing related to the forum post at hand and is basically spam, thanks!

I was pointing out how to use the forum and find the information you were requesting, did you look at the areas I suggested that you look at?
BTW sorry if I was a bit abrasive/rude

when i did the ( MESA_VK_DEVICE_SELECT=list vulkaninfo) command, i got this:
[cassie@bunny-device ~]$ MESA_VK_DEVICE_SELECT=list vulkaninfo
ERROR: [Loader Message] Code 0 : loader_scanned_icd_add: Could not get ‘vkCreateInstance’ via ‘vk_icdGetInstanceProcAddr’ for ICD libGLX_nvidia.so.0
ERROR: [Loader Message] Code 0 : setup_loader_term_phys_devs: Failed to detect any valid GPUs in the current config
ERROR at /usr/src/debug/vulkan-tools/Vulkan-Tools-1.3.269/vulkaninfo/./vulkaninfo.h:237:vkEnumeratePhysicalDevices failed with ERROR_INITIALIZATION_FAILED

this issue disappears when i have nvidia downloaded, but ofc, the issue is then that my brightness is maxed and the screen flickers black incredibly disorientingly, i want to assume the AMD driver must be downloaded as otherwise? my computer would be running no graphics card and not be showing much of anything? but i might not be understanding something about the nature of these things

yes ages ago like i detailed in the post, didn’t find the information i was looking for, thats why i made the post because i couldn’t find the information about my issue in the existing information, as thats why you make posts about issues you’re having

to be more clear on this, the OpenGL information in my system settings say they’re trying to run an AMD processor, so by all accounts it should be using that

I must have been unclear sorry for that the page I was trying to get you to look at was this
It will help people understand your system more and you will get more relevant advice.
It is the first option under the Help on the top left of the forum. I’m no expert so I probably won’t be of much help after this but as I said it wil help others help you. If you are unsure about what is on that page ask a specific question, there are a lot of people whose first language isn’t English so this makes it easier for them to translate,

I haven’t tested what I said with an Nvidia gpu and and AMD gpu, I just have two AMD gpu’s in my system. The other option you could try is to blacklist the Nvidia driver so it doesn’t load and that your system that is force to use the AMD gpu.

i mean, i uninstall the nvidia driver entirely whenever i try it out because the constant black screen is annoying, hell this whole issue seems to be centered around my computer refusing to properly use the nvidia driver, however, without it, i still can’t change my brightness (though its not at max which is nicer) and i still cant run games at any decent speed, and every time i try using some command to check what my computer is using for a driver, i get an error message instead! i’ve tried following through installation guides for nvidia and amd, and neither have changed anything about the problems i’m facing whatsoever

i know for sure my computer has a nvidia quadro p1000 card, for sure, i’ve tried following EVERY guide for proper installation i can find, and all of them give me the same issue which i’ve posted about, if i have an AMD card, i can’t seem to find it with any commands i’m using, the only evidence i have that there might be one is OpenCL and OpenGL both seem to think they’re trying to use one

Try blacklisting the Nvidia driver, something like this or you can try disabling the Nvidia gpu in you computer’s bios.

its blocked, that changed nothing, as the nvidia driver was not being used, i still cannot adjust my brightness, i still get the exact same error message when using the commands you specified, and everything still runs at 10 fps or just does not run at all, this would be i suspect because, as i’ve said, i uninstalled the nvidia driver after it gave me no improvements and worse issues