NumLock not working in HyperX Alloy FPS keyboard in KDE Plasma

NumLock not working in HyperX Alloy FPS keyboard in KDE Plasma, it automatically selected the Generic 104 with Intro in L Shape, but when i go to settings to activate the NumLock at the Plasma start, it won’t work, i’ve selected Activate and also keep without changes and it always turns off :confused: any idea? how could i make it work? and if it’s not much to ask, is there a way to configure the RGB lights on the keyboard?