Number Lock Disabled on Boot

I have enabled Restore num lock state on startup but it’s always disabled

Screenshot from 2020-08-20 20-21-59

I can’t figure out why it happens . Hope someone can answer :smiling_face_with_three_hearts:

First place I would look is in you BIOS - you might just be toggling it the wrong way! I still don’t really understand why it is still a ‘thing’. We’ve had dedicated cursor keys for MANY years now… :grin: (yeah, laptops, I know - and maybe 10-keyless gamers too)

2 Likes

Usually the DE has a way to permanently change numlock.

And there’s a small utility package numlockx that might help too.

4 Likes

I used the way DE has and it did nothing . The utility works partially I’d say . Because I cannot type any numbers with numlock off but can change workspace :roll_eyes:

Screenshot from 2020-08-21 09-32-39

Does this have anything to do with it , also is there any command line way to fix this (i.e. how to edit Xfconf ) cause I don’t think GUI can help

Anyway I am keeping the utility , thanks @manuel

xfconf-query is a CLI tool for Xfce settings. Try xfconf-query --help for more info.

1 Like

Got this far , now what ?

Screenshot from 2020-08-21 17-07-37

Screenshot from 2020-08-21 17-09-17

This is a boolean number , what value should I set and how to do that via command line .

You’re missing one more entry in your settings:
Bildschirmfoto_2020-08-21_16-20-58

…and I found this in the XFCE4-Forum:

1 Like

You have to replace VALUE with “true”
…and “leer” is German for “empty” :grinning:

1 Like

OK Fixed it

I reset everything in Xfconf editor in keyboards section and set numlock on with the command

xfconf-query -c keyboards -p /Default/Numlock -t bool -s true --create

and this entry appeared
Screenshot from 2020-08-21 20-16-53

Then selected restore numlock on startup in keyboard settings and the second entry appeared
Screenshot from 2020-08-21 20-17-02

So if you have any problem with Xfconf resetting all options is a good idea !

Thankyou @Tinymeat

1 Like

I found this in the Arch-Wiki:

NumLock on by default

Install the numlockx package and then edit /etc/lightdm/lightdm.conf:

/etc/lightdm/lightdm.conf

[Seat:*]
greeter-setup-script=/usr/bin/numlockx on

3 Likes

But numlockx won’t help with typing numbers from numpad . I think the issue was with Xfconf so resetting it solved it .

I would’ve marked Tinymeat’s answer as solution but that could be achieved using the settings manager and the issue was something else .

Anyway thank you @freebird54 @manuel @Tinymeat and @Scruggs for helping :smiling_face_with_three_hearts: :smiling_face_with_three_hearts: :smiling_face_with_three_hearts: :smiling_face_with_three_hearts:

1 Like