NTFS Copy Results in 0b Files

Hello. I’m a newbie user of Endeavour. But have used Linux for quite awhile
I have a dual boot installation of Windows 10 and Endeavour with third partition (NTFS) as shared storage for both Windows and Endeavour

Recently, I’m experiencing weird issue. Whenever I try to copy a file (let’s say, an ISO file or zipped folder) to the shared storage, the resulting file is 0b. So I can’t do anything with the copied files

This also happens when I copy a file in that shared storage from a folder to other locations in that shared storage

This doesn’t happen in Windows 10. And copying works normal

Before, I experienced this with Manjaro Linux months ago. That’s why I decided to jump ship to Endeavour. But after a while, turns out this issue also appears in Endeavour

My system is up to date. Last update was last night

I found a link about this exact same issue in Unix Stackexchange from March. But unfortunately it has no reply

Not that it solves your NTFS problem, but I have always used fat32 partitions for sharing between Windows and Linux because its much less prone to problems.

Make sure you have disabled “Fast startup” in Windows. Otherwise the disks will be marked dirty and disk behavior will be inconsistent.

It’s already done long ago. I disabled hibernation as well. GParted reported something about $MFT stuff, but I didn’t get to copy the exact report. Gonna look at that later and post complete report

It’s really weird. I did this exact combo for years now. But just recently got this issue

Bumping up

I have never trusted NTFS for anything, even under Windows. The early days of NT 3.51 and 4.0 left a very bad impression and I had stuck with fat32 since the late 90’s. :rofl:


I tried to copy a small zip file (under 3MB). Thunar and Dolphin still report 0b. Then I rebooted and enter Windows. The file is fine and can be extracted

Boot back to Endeavour and yes, the file size reported correctly this time

I wonder if this is a bug

Cz I extracted a different zip file containing a video under Endeavour and couldn’t get it to play. Too bad I deleted the said zip file so I can’t replicate the experiment


I’m tired
Decided to wipe the partition and change it to ExFAT

Consider this solved

For future reference - you could have tried ntfs3 kernel driver

I was researching about it few days ago, after the convert. But I read that there’s still some hurdles with Paragon Software. So I hesitated to install it. Thanks anyway! Might take it into consideration when I upgrade my machine

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.