Notes for anyone that wants pamac-all ->Plasma install

I thought it may or may not be relevant to post this, but I’ve seen no mention of this yet,
so, anyone reading this, please feel free to interject and add thought, corrections and/or experience with this.

A week or so ago I had my Pamac act wonky, don’t remember exactly what, but after some searching, with said Pamac installed, I ran across pamac-all

I may or may not be correct, but I believe it’s from the the same maintainer as pamac-aur-git, it’s the same link anyway…

I had a few glitches that I’m sure were my fault as far as getting things switched around, but got them solved.

Here is what I did as of tonight because this would be the fourth machine fixing, the laptop after the 3 desktops.

For Plasma, it’s real easy… but may help others as well

  1. uninstall pamac-tray-indicator & pamac-aur-git …whatever version
  2. keep archlinux-appstream-data
  • If you do this, should probly use cli, because you may get error because pamac is running.
    as of tonight when doing the laptop, my root password wouldn’t work to upgrade after uninstall unless I rebooted “weird”
  1. Install pamac-all … I used the #1 defaults for the install, not sure there was any I noticed on the desktops, but the laptop had more options, I still went with 1 default.
    I’m sure it’s the hardware it’s seeing is all.

Now right off, the pamac tray has yet to work on boot, BUT, just type in autostart on the begins button, click add, then just type in pamac-tray, enter, done, reboot if you want, and it’s running at startup.

I clean-built the pakages, so you’ll have to goto prefs and turn on aur support, enable downgrade, check disk space, check for updates in aur…

…and no problems yet that impresses me, I checked under the cache option, Remove only the versions of uninstalled packages.

Now for me, on my desktops, this freed up over 2GB of space on each one…on my laptop, it cleared up 5GB of space…
No problems on any machine for a week, but just did the laptop now lol.

The only thing I’ve noticed, not a HUGE deal, but more of a prefer, but like I said, I may not have something set right,
I prefer for whatever used to tell me to reboot after important file upgrades.
I do not know if this is an endeavour thing or a pamac thing, but I’ve not see this msg for awhile.

My suspicion is Endeavour, not upset, only guessing something may be broke…
…this is the part where you guys tell me I’m right, wrong, or check this, or whatever… just saying,
I’ve had linux-lts updates, but no popup telling me to reboot…again, not bitching, these are only observations.

regardless, pamac working again great, hiccups gone.

Hope this post helps in some way.


I only use pamac as a search & info tool, so I am not sure if it ever notified of required reboots. But the option is there if you press the arrow button at the bottom right-hand corner. Not only will you be able to see what it is being done, but most importantly, all messages & warnings (like the one that you need to reboot).

That’s what I mostly use it for as well, great tool!

1 Like

I had the same problems with Pamac, so I switched to Bauh which also has Snap channel support and appimage support.

The reboot thing on Pamac I also had never on Manjaro, so maybe I had a older Pamac or I had disabled that option