Not resuming after hibernate

Good day fellow Linux legends.

I’ve freshly installed EOS on 2 different Dell XPS laptops, 13" 9360 and 15" 7590. I chose the online install option. No dual-boot, only EOS installed. I’m also using KDE Plasma. I’ve not tried other DEs but I did try Manjaro and it works fine with that distro. Swap with hibernate was enabled during the install.

Hibernate works just fine but the problem is waking up after hibernating. It simply just reboots to the boot selection menu instead of restoring the session prior to hibernation.

I’m using systemd boot but I’ve also tried with a fresh install with grub and it does the same thing.

I tried the things mentioned on the EOS forum post: Laptop not resuming from hibernation - #7 by petsam but to no avail.

  • I have checked to make sure “resume” is in dracut.
  • The uuid for resume is correct in /etc/kernel/cmdline.
  • lsinitrd shows the resume module.

I’m not sure what else to look out for or where to check.

Thanks team.

EDIT:
The solution is to ensure /etc/dracut.conf.d/resume.conf contains:

dd_dracutmodules+=" resume "
install_items+=" /usr/lib/systemd/system/systemd-hibernate-resume.service "

and then:

sudo dracut-rebuild

1 Like

Please have a look at the following post and see if it will resolve your issue as well:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.