`not in sudoers file` and not booting properly

Today I noticed something different. I could not do sudo. Naturally, I rebooted the computer to hopefullt fix the error. Then I got to an empty screen. No login screen or anything. Tried all the buttons on the keyboard. Turns out, that if i press F9 or F10, i get to login screen and I successfully logged in.
But the sudo error remains. I am in the wheel group. I logged in as root in a prompt and ran visudo and uncommented %wheel ALL=(ALL:ALL) ALL
Of course it did not help so that is why I turned to you guys.
Is there any other way to mend this problem without reinstalling the entire system?

What specific error message do you get when you run sudo?

I restarted once again and was just about to give you the console output of the error but then it magically worked fine. But the blank screen upon booting still remains though. Guess that has something to do with the autologin that is no longer working as it used to.

Does such things happen with EndeavorOS that sudo stops working by itself?

The most common reason is that the wrong password is entered and the account is locked for a few minutes. You can look in the logs and see if that happened or not.

I had the issue with account locked recently while messing around with the btrfs application development… dont know what i did that it thought i attempted to sudo incorrectly enough to lock it, but it says Sorry, try again for that.

1 Like

I think the default number of failed attempts is pretty small.

Looks like according to my /etc/security/faillock.conf from EndeavourOS it’s set to 3.

1 Like

The default is 3.