Not breeze cursor at sddm


The cursor theme isnt breeze.

  • tried synchronize settings
  • editing /etc/sddm.conf
    both didnt work.

Breeze theme

Am i only one having this problem

Try /etc/sddm.conf.d/kde_settings.conf worked for me.

:edit: Though I use Bibata, not Breeze

1 Like

Welcome to the forum @hellojack :partying_face: :tada: :balloon:

1 Like

I’ll try when i can access my pc! thank you for suggesting

Thank you for greeting!! :smiling_face_with_three_hearts:

I suppose you’re using KDE Plasma with SDDM. If not, ignore this post.

Open System Settings, navigate to Startup and Shutdown, Login Screen (SDDM). There, on the bottom of the window you’ll find a “Synchronise Settings…” button. Click on it, click on “Synchronise” and enter your sudo password when prompted. Close the window and reboot. You should now see the same theme on SDDM as you are using on Plasma.

Welcome to the forum, btw. :slight_smile:

Welcome @hellojack

I am running KDE Plasma and mine is running breeze cursor as shown by the image. Go into system settings, appearance, cursors and check. As the others have said also check the synchronize settings button. I’ve never had to use this before but i do find if you start mucking about changing icons and things sometimes KDE can get messed up.



Yes… I see he did say he tried that. Ive never had to use it. What is it tied to the theme?

I wish I could help since I had this issue after a fresh install on 5.20, but the synchronization worked for me after 5.21 rolled around.

What does the synchronization do? Is it based on the theme you are using?

@ricklinux it just updates the sddm config with the cursor theme you have set in plasma.

1 Like

The strange thing is that it was synchronizing any other cursor theme just fine, but went back to DMZ if Breeze was selected. Is this what’s happening with your install @hellojack?

Found a possible problem with glib2, I am wondering if this is also affecting this??

Thank everyone for helping! :heart_eyes: :star_struck:
I have fixed it by :
Apply Breeze-Dark system theme → Synchronize settings → Then again change to Breeze theme(which i want)