Not booting to Plasma DE after installation

I have tried using the online installation with Plasma selected and upon booting I am presented with the command line to login. The DE has not booted.

I used Rufus to USB boot.

I have Nvidia gpu and tried both standard and Nvidia non-free boot which both do not boot plasma.

I can boot XFCE fine using the offline installer.

I am using separate SSD for install and selecting erase option.

Any help is appreciated! :slight_smile: Not an advanced user.

If you login and then run systemctl list-units --failed what is the output?

Oh do you now? It couldn’t possible be…

…I bloody knew it. Go search. You’ll find your answer.

There is an issue with nvidia drivers installing and setting up correctly sometimes. I’m not sure if that is your issue as I see you used Rufus to create the live usb also. Did you install using the non free driver entry in the menu of the live usb. If you can log in and post the out put of

inxi -Ga

It’s strange because i never seem to have this issue installing with Nvidia.

Same issue with me! I just created an account here just to say the same thing. The error persist in offline and online instalation. I tried three times, btrfs installation online, btrfs installation offline and XFS instalation online. All the three times using the non free mode on boot for installation. The funny thing is that I already have used this ISO in the same pen-drive last Friday with no issues. After distro hopping I was returning to endeavour but that issue occurred. I tried the tips here on the forum about black screen, but nothing worked. Even pacman wasn’t working with that mirror tip, returning URL error. Tomorrow I will try the installation again and I will return here to say if worked or not

Ps: sorry for my bad english

Welcome @Cacique
On Friday there is a new ISO coming that you will be able to download that should resolve these issues. If you are going to try another install then i would recommend you add nvidia-dkms as a package in the following file on the live installer before you start the install.

user_pkglist.txt

Use sudo xed and then open /liveuser/user_pkglist.txt and add

nvidia-dkms

Save the file and then start the installer and run through the install process.

Example:

Note: This is only for the online install only!

1 Like

I did a reinstall including the package you listed just in case it was that, but have the same result.

Thanks for quick response. Your command output was “0 loaded units listed”.

How about systemctl status sddm

I have launched plasma by using commands

systemctl enable sddm
systemctl start sddm

How do I enable this on startup?

1 Like

Executing these commands should start sddm.service at boot as well.

Thanks for the help, guys

1 Like

Strange that sddm wasn’t enabled by default. :thinking:

1 Like

Just want to add that my USB WiFi adapter worked on liveboot, but didn’t work after install. Had to use command:

systemctl start NetworkManager

I believe everything is working as it should now. Thanks again.

If you need that a service gets started at future boots as well, you need to run the enable command too. The two commands can be combined:

sudo systemctl enable --now XXXXXXX.service

1 Like

It seems like for some reason the services didn’t get enabled on your system. Did the install finish without errors?

As far as I’m aware. Is there a log that I can check for installation errors?

Here the problem persisted. I reinstalled and continued on black screen with just the terminal. I started SDDM as spoken here and it worked. Just like the user up there, the internet wasn’t working, I started too and everything seems to be working as it should now. The installation did not have any errors, however, this happened. Now everything is working as expected. Thank you all for your attention!