Not able to use Wayland or to choose a different session from X11 Gnome

Hi all,
New EndeavourOS user here.
It’s been really great and, barring the issue that gnome accounts seems to not be enabled (and I still haven’t got around to fix it, although I’m managing with webDAV and calendar integration in apps for now), smooth sailing.
I’m however a bit baffled as to why, when i log into GDM, i can’t choose sessions. It’s kind of annoying cause I wanted to try Hyprland but i can’t seem to get GDM to show me the choice of sessions for the life of me. I tried to fumble a bit with what was in the Arch wiki, but to no avail.
I would be immensely grateful if you could help me.
It occurs to me that i should mention i’m on Nvidia if that helps.

I am not in front of gdm right now, but did you try clicking on the gear in the bottom right corner of the screen? I think that is where it is located by default.

There’s no gear, which is why I’m asking for your help, sadly. I thought it was some kind of odd conservative choice made in the installer, but now I’m not so sure.

Can you send a picture of your GDM screen?

The option might be there on top right.

Can’t really stamp, i’ll use a photo hoping it’s clear enough
IMG_3864

Can you show us the contents of nano /etc/gdm/custom.conf and copy and paste that output here

Edit: Also are you on Nvidia?

2 Likes

GDM configuration storage

[daemon]
AutomaticLoginEnable=False

Uncomment the line below to force the login screen to use Xorg

#WaylandEnable=false

[security]

[xdmcp]

[chooser]

[debug]

Uncomment the line below to turn on debugging

#Enable=true

Also yes I am on Nvidia, sorry for my forgetfulness

Ok thanks, having the line #WaylandEnable=false means that when you turn on your system, GDM will automatically default to Wayland. This is a default Gnome has set, not EndeavourOS, but when having Nvidia it requires a little extra work to get up to speed. When you are logged in, are you running Wayland or Xorg? You can verify this in Gnome Settings > About > Windowing System and it’ll say either Wayland or X11 (xorg)

It’s X11, so I guess that default isn’t working.

Well technically that comment for #WaylandEnable=false is accurate as it’s a config ONLY set for GDM. I just wanted to see what your system defaults to and that’s X11. THe GDM .conf file is fine, we can leave that alone for now. The real question is how you installed Nvidia? and if you’re running off the proprietary drivers or not because previous versions of GDM blacklisted Nvidia

Edit: did you set nvidia-drm.modset=1 in /etc/default/grub btw or no?

Are they aware of what “uncommenting” means?
(I.e. deleting the # in front of the line?)

Just asking.

Try this option for now, where you’ll edit the file, save it, reboot, and at the login screen let us know if the gear/cog icon shows up when entering in your password.

sudo nano /etc/gdm/custom.conf

Change #WaylandEnable=false to WaylandEnable=true, where you delete the # in front and change false to true. Then Ctrl + X, then Y for yes to save, and ENTER to exit.

Then reboot your system and let us know if the gear does show up now or not.

Will do.
@ivanhoe i do know what that means, I’m new to EndeavourOS but i’ve been running some flavor of Linux since like… 2018 and… let’s just say I have some programming/IT experience. It’s just that the whole X11/Wayland thing has always been a non-problem in the distros i used in the past and i could run different DEs without issue.

1 Like

What are the outputs of

inxi -Ga

and

pacman -Q | grep wayland

For example: My gnome setup has these:

[derek@Legion5 ~]$ pacman -Q | grep wayland
lib32-wayland 1.21.0-1
wayland 1.21.0-1
wayland-protocols 1.26-1
xorg-xwayland 22.1.3-1
[derek@Legion5 ~]$ inxi -Fza

and

Graphics:
  Device-1: AMD Navi 23 [Radeon RX 6600/6600 XT/6600M] vendor: Lenovo
    driver: amdgpu v: kernel arch: RDNA-2 code: Navi-2x process: TSMC n7 (7nm)
    built: 2020-22 pcie: gen: 4 speed: 16 GT/s lanes: 16 ports: active: none
    empty: DP-1, DP-2, HDMI-A-1, eDP-1 bus-ID: 03:00.0 chip-ID: 1002:73ff
    class-ID: 0300
  Device-2: AMD Cezanne vendor: Lenovo driver: amdgpu v: kernel
    arch: GCN-5.1 code: Vega-2 process: TSMC n7 (7nm) built: 2018-21 pcie:
    gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s ports:
    active: eDP-2 empty: none bus-ID: 08:00.0 chip-ID: 1002:1638
    class-ID: 0300
  Display: wayland server: X.org v: 1.21.1.4 with: Xwayland v: 22.1.3
    compositor: gnome-shell driver: gpu: amdgpu display-ID: 0
  Monitor-1: eDP-2 model: BOE Display 0x0a81 built: 2021 res: 1920x1080
    dpi: 142 gamma: 1.2 size: 344x194mm (13.54x7.64") diag: 395mm (15.5")
    ratio: 16:9 modes: max: 1920x1080 min: 640x480
  OpenGL: renderer: AMD RENOIR (LLVM 14.0.6 DRM 3.47 5.19.5-arch1-1) v: 4.6
    Mesa 22.1.7 direct render: Yes

These are the outputs:
for inxi -Ga:

12Graphics:
  12Device-1 NVIDIA GA104 [GeForce RTX 3070] 12vendor PNY 12driver nvidia 12v 515.65.01
    12alternate nouveau,nvidia_drm 12non-free 515.xx+ 12status current (as of 2022-07) 12arch Ampere
    12code GAxxx 12process TSMC n7 (7nm) 12built 2020-22 12pcie 12gen 2 12speed 5 GT/s 12lanes 16 12link-max 12gen 4
    12speed 16 GT/s 12ports 12active none 12off DP-3 12empty DP-1,DP-2,HDMI-A-1 12bus-ID 2d:00.0
    12chip-ID 10de:2484 12class-ID 0300
  12Display 12server X.org 12v 1.21.1.4 12with Xwayland 12v 22.1.3 12compositor gnome-shell 12v 42.4 12driver 12X
    12loaded nvidia 12unloaded modesetting 12alternate fbdev,nouveau,nv,vesa 12gpu nvidia,nvidia-nvswitch
    12tty 80x40
  12Monitor-1 DP-3 12model LG (GoldStar) 27GL850 12serial <filter> 12built 2020 12res 2560x1440 12dpi 109
    12gamma 1.2 12size 597x336mm (23.5x13.23") 12diag 685mm (27") 12ratio 16:9 12modes 12max 2560x1440
    12min 640x480

For pacman:

egl-wayland 2:1.1.10-1
lib32-wayland 1.21.0-1
qt6-wayland 6.3.1-1
wayland 1.21.0-1

Gear does not show up. I installed nvidia proprietary via pacman, not with the initial installer. Yes, i got DRM modeset on 1.

Just by chance, you could try this?

  • Editing /etc/gdm3/custom.conf and uncommenting “WaylandEnable” setting it to “WaylandEnable=true”
  • Editing /usr/lib/udev/rules.d/61-gdm.rules and commenting out the line that says if nVidia driver version greater than 5.10 is detected then use X11

The custom conf is in gdm: already tried, no gear.
Will try editing udev rules: i’ll get back to you.

Which one of the lines should i commenti?

# Disable wayland when nvidia modeset is disabled or when drivers are a lower
# version than 470,
# For versions above 470 but lower than 510 prefer Xorg,
# Above 510, prefer Wayland.
KERNEL!="nvidia_drm", GOTO="gdm_nvidia_drm_end"
SUBSYSTEM!="module", GOTO="gdm_nvidia_drm_end"
ACTION!="add", GOTO="gdm_nvidia_drm_end"
# disable wayland if nvidia-drm modeset is not enabled
ATTR{parameters/modeset}!="Y", GOTO="gdm_disable_wayland"
# disable wayland for nvidia drivers versions lower than 470
ATTR{version}=="4[0-6][0-9].*|[0-3][0-9][0-9].*|[0-9][0-9].*|[0-9].*", GOTO="gdm_disable_wayland"
# For nvidia drivers versions Above 510, keep Wayland by default
ATTR{version}=="[5-9][1-9][0-9].*", GOTO="gdm_end"
# For nvidia drivers versions 470-495, prefer Xorg by default
GOTO="gdm_prefer_xorg"
LABEL="gdm_nvidia_drm_end"

GOTO="gdm_end"

LABEL="gdm_prefer_xorg"
RUN+="/usr/lib/gdm-runtime-config set daemon PreferredDisplayServer xorg"
GOTO="gdm_end"

LABEL="gdm_disable_wayland"
RUN+="/usr/lib/gdm-runtime-config set daemon WaylandEnable false"
GOTO="gdm_end"


No if-statement in that file.

How about changing kernel parameters in /etc/default/grub, then updating grub and rebooting?

nvidia-drm.modeset=0

Also.

Sorry, got to go now, it’s getting late here!