Not able to type password after screen locks

I gave in to all of the hype I’ve read on here and drove into XFCE some this weekend. So far, so good with everything. I still have a lot of tweaking to do, but I’m working on all of that. I did see one issue so far though. A lot of the time (maybe all, I can’t say that for sure though), when I come back to the session the login screen won’t let me type in my password. I am able to highlight the “Enter your password” text in the space I would normally type my password, but when I type anything it doesn’t change. The keyboard is working though, because hitting caps lock brings up the warning that caps lock is on. I also know that it’s not just dots showing up in that field because clicking there, typing the password and hitting enter tried to check the password, but tells me it’s the incorrect password. If it matters, this is an install in virtualbox on win10 and I haven’t had this issue with other DE’s (mainly tried cinnamon) and it doesn’t happen on the initial login to XFCE. Thanks in advance for reading this and any help.

You might want to take a look at this Topic
It might help you with your problem.

Pudge

This is more related to an unsolved upstream bug on xflock. It will help to press [Ctrl+alt+F2] and [Ctrl+alt+F7] then it should work again to type password, you can change also to another locker.

I had this problem consistently with the combination of lightdm/light-locker on Arch (before EOS existed) and on the rolling release of Sparky Linux. Annoyed me so much on Arch that I removed light-locker and installed xscreensaver (ugly password dialog, but worked just fine…). On Sparky, it was the last of a long series of breakages, so I stopped using Sparky :slight_smile:

I’ve not seen the problem at all since I switched to lightdm/xfce-screensaver (which I did after my first EOS install).

Thank you everyone for the quick replies.
@Pudge - I don’t think that post is related, that’s talking about the password in the terminal from what I saw.
@joekamprad - pressing [ctrl+alt+f2] gets me to the cmd line where I can login, but I don’t know how to get back into xfce from there (me = n00b)
@toothandnail - I see xscreensaver 5.44-1 as installed. What do I need to do to switch to this?

I think @joekamprad was suggesting that you merely ‘visit’ the console, and then immediately return to XFCE by using [ctrl+alt+f7] - which should be ‘reactivated’ so you can login there. Probably a good workaround for now.

1 Like

Oh. I knew about the [ctrl+alt+f2] to get to the cmd line, but I didn’t know about [ctrl+alt+f7] to get back. Unfortunately, going to the cmd line and coming back doesn’t seem to reset anything. When I get out of the cmd line it comes right back to the same screen and I am still unable to type anything into the password section.

Drat - sometimes that works… :grin:
Anyway - I guess you need to try a different screenlocker. I am no expert at this aspect of things, but my understanding of XFCE is that it will look for whatever screenlocker is available from a list of probables, so removal of the troubled one, and installation of another should be pretty easy. The change can be implemented from the console, and you can restart from there too.
Or you can wait for someone who knows more to give you more precise guidance :smile:

I’m tried the lighdm/xfce4-screensaver combo and I’m still having the same issue. @joekamprad the value I’m seeing for that property is blank (in this EOS install and another distro with xfce I was messing with in a VM), so I’m not sure what it would need to be. Thanks.

https://wiki.archlinux.org/index.php/Xfce#Lock_the_screen

is the one used by default if xfce4-screensaver is installed :wink: so the one failing for you before also…
I would try light-locker:

sudo pacman -S light-locker
xfconf-query -c xfce4-session -p /general/LockCommand -s "light-locker-command --lock" --create -t string

light-locker it is integrated into xfce4-settings also after installing it, and it is working here.

is the one used by default if xfce4-screensaver is installed :wink: so the one failing for you before also…

2 Likes

Thank you for walking me through that @joekamprad. I was thinking that light locker was the issue, so I was moving in the wrong direction completely. I uninstalled xfce4-session, installed light-locker and entered the line you gave. I also check in the settings editor (where your screen shot is) and made sure that was set to “light-locker-command --lock”. Everything looks to be working well now. Thanks everybody for the assistance.

xfce4-screensaver hopefully :wink:

You are welcome!

Yes, screensaver, not session. I type better in the terminal than I do in here. :smiley:

1 Like