Not able to start snapd applications

hi, newbie here, I’m having an issue with snapd applications, after install complete i cannot start them, i tried using terminal to see if i can see some log of the app, but it doesn’t show anything.
the apps i tried are spotify, onlyoffice and wps office.
I’m running the atlantis release with gnome.
I also have an issue with qt video capture utility, it only shows a blank screen.

How did you setup snap services on your computer?

If you didn’t, you will first need to install snapd and start the service.

If I were me, I wouldn’t waste a minute on a snap application though, and would go straight for the AUR.


There are AUR packages for spotify, wps-office, onlyoffice-bin.

1 Like

I removed them from snap, installed onlyoffice from the AUR instead, but still the same issue.
running onlyoffice from terminal gives this error:

This application failed to start because it could not find or load the Qt platform plugin "wayland"
in "".

Available platform plugins are: linuxfb, minimal, offscreen, vnc, xcb.

Reinstalling the application may fix this problem.
Aborted (core dumped)

but when i run

QT_QPA_PLATFORM=xcb onlyoffice-desktopeditors

nothing shows up

I think you have to install qt5-wayland

Edit: Are you using Wayland?

Sounds like a feature to me, not a bug. Just ask Linux Mint devs.

On a slightly more serious note, consider not using snapd. Read this post to find out why:

Most applications that exist as snaps can also be installed form the AUR.

yes, i’m on wayland, and i already have qt5-wayland installed

thank you, i went back to only using AUR, but the issue still there.

I don’t know much about the error message. It may be looking for the path to the plugin? Not sure.

from what i read, onlyoffice does not support wayland, and it falls back to xcb, but even when i run it with xcb nothing happens XD.
i managed to get telegram working with wayland no isssues.
but this thing gave me a headache.
i’ll continue looking up for a solution, if i found one i’ll let you know.

1 Like

Ahh then logout and back in choosing xorg and try again… Else use libre office. It works.

i tried it and it worked, thank you.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.