Not able to save state slots

Hello, this is my first topic in Gaming Section.

I mostly play GBA and NDS games on my desktop, like Pokemon,Castlevania,legend of zelda, etc.
But the issue is that I am not able to save the game slots in emulator as well as rom folder, due to which I am unable to progress in the games.

GBA emulator(s) : VBAM-wx, mGBA
NDS emulator : DesMuMe

what should I do in order to save the progress ?

My first guess would be, that you have no rights to write into that folder or the rom, because your user lacks the permission. Maybe you specified a folder where to save, but that folder doesn’t exist or is outside of your writing permission? Or the rom is faulty and the emulator doesn’t save it properly. You should also ask on the respective emulator forums for help.

How can I change the user rights ?

Wher are your ROMs stored? I always place them in my home folder and have not had any of these issues before.
I haven’t used desmume for a while now but I know you can also set the save and save state paths in mgba

In VisualBoyAdvance, the save slot directory is in /tmp folder.

As you mentioned in image, I changed the path of directory but it is not working in VBA-M but is working in mGBA.

In this case, I think I should try to accommodate myself with usage of mGBA.

:saluting_face:

The real trouble is in saving and loading by (shift+Fi) and (Fi) respectively. i=1,2,3,…n .

When I press keys for saving, it shows that it cannot write in the specified directory.

Then you should try to change the save directory to something in your home folders.

2 Likes

Does it work from the menus?

I just tried vbam-wx and without changing any settings the save works shortcuts. I would suggest moving your roms into your home folder as the default for save states is to save it in the same directory as the rom

1 Like

This is what happening:

Do you get the same thing happening with other roms or just this one?
Have just tried this rom and the latest version works, I did notice however that the version you have is out of date by about a year, maybe try out the latest version as well and see if that works as expected

I downloaded 2 new roms.

  1. Pokemon Glazed
  2. Pokemon Ultra Shiny Gold Sigma

This error is occurring in both of these as well.

I’m at a loss then, hopefully someone will be able to help

Could you share the output of this command, please?

\ls -la ~/.local/share/visualboyadvance-m/
[deweshk@HomeDesktop ~]$ sudo \ls -la ~/.local/share/visualboyadvance-m/
ls: cannot access '/home/deweshk/.local/share/visualboyadvance-m/': No such file or directory

One last thing I didn’t think of was how did you install it?
Also have you tried to change the directory to a different folder?
Screenshot_20220215_023013

I had installed via yay -S.

I had also changed the directory to the desired location by same method, but it didn’t worked.

Have you tried to change it manually?
/home/smokey/.config/visualboyadvance-m/vbam.ini
Screenshot_20220215_033116
Change this line

No, no, don’t use sudo! Did I tell you to use sudo? No, so why do you use sudo?

You should never use sudo when you don’t need to, you’ll just mess up your file permissions! Especially in your home directory, there is never need to use sudo there. Also, never run GUI programs with sudo.

The directory does not exist. So, create it (without sudo!):

mkdir -p ~/.local/share/visualboyadvance-m/
3 Likes

Thank You sir. It is working now as expected.

My question is how will I know that when should I need to use mkdir ?

Also, I used sudo because I thought I need to provide it. The reason behind this is; when I press Ctrl + O to open ROM, it opens up the Filesystem root. That’s why I thought I need to provide admin rights.

I will remember your advice regarding sudo , hence will not use it for things which are in /home directory.
So, I need to provide admin rights only when I am performing tasks which are related to functionality of the system ?