Not able to boot into the desktop environment after using the online installer

Hey, I’ve been trying to install Endeavour OS since yesterday and I’m getting desperate :sob:. Endeavour doesn’t seem to like me :worried:.

My Journey:
I downloaded the EndeavourOS_Apollo_22_1.iso from https://endeavouros.com/latest-release/ and here from Alpix. Flashed it to a USB stick with the Balena Etcher and booted into the live session with the Nvidia drivers. There I updated the mirrors and started the online installer. Wipe the SSD and create a btrfs. In my first attempt of at least 5342450 tries :face_with_spiral_eyes: I selected KDE Plasma and took out the Intel and AMD GPU drivers as well as Firefox, Dragon and KDEconnect. The installation runs without errors and says I can reboot now. I did that after pulling the usb stick, but after the grub boot manager the system does not boot into the desktop environment. Instead I see a terminal view in which the lines run down so fast that you can’t read them at all. At the end I can’t scroll up either.

OK I thought a new try. Stick inserted - everything made as just described, but now I have taken out no packages and left everything as it was. Same game installation runs through, reboot terminal view instead of desktop environment.

OK I thought maybe something is wrong with KDE, so next round with LXQT, same result.

Now I tried the offline installer. After the installation the system boots into the desktop environment and everything works fine.

But I did not want to give up yet. Another USB stick, the same ISO on it - same result.

Then I found this page https://endeavouros.com/news/apollo-iso-bug-is-fixed-for-most-users-and-also-a-workaround-for-those-who-need-it/ and tried to update Archlinux-keyring via the terminal before the installation. No success - same result.

I did the offline installation again and did the described https://endeavouros.com/news/apollo-iso-bug-is-fixed-for-most-users-and-also-a-workaround-for-those-who-need-it/. The result was that after a reboot I could not boot into XFCE anymore.

At this moment I tried to log in to the forum, unfortunately I can’t open any topics with my first account even after several hours. OK I thought maybe it will take some time to unlock.

Then I stopped for that day and continued today. Now I have tried as described here https://github.com/endeavouros-team/EndeavourOS-ISO to create an own ISO. Unfortunately this ISO was not able to boot into the live session.

Then I tried to flash a stick on a Windows notebook with Rufus (with the own iso) and the same result.

Thought now that can not be and to exclude everything installed Garuda Linux and Manjaro with KDE. With both no problems.

Now I downloaded the ISO EndeavourOS_Apollo_22_1.iso from https://endeavouros.com/latest-release/ but this time from Freedif. I have now tried countless variations with other USB sticks, other USB ports etc. always the same result. Since after the Grub Bootmanager the lines fly down only in such a way that you can’t read them, I came to the idea to record the screen with a camera in the time lapse. On the Video I found out that it shows “Failed to start load Kernel Modules”.

Next try I installed the LTS Kernel and the Zen Kernel. But that didn’t help either. Then I noticed that I still can’t open topics with my first registered account and I registered here again with this account and now I hope that someone can help me.

So summary stand now the PC boots after the offline installation in XFCE at least until I run sudo pacman -Syu and reboot. With the online installer I have not yet found a variation that boots into the desktop environment.

System:
  Kernel: 5.17.1-arch1-1 arch: x86_64 bits: 64 Desktop: Xfce v: 4.16.0
    Distro: EndeavourOS
Machine:
  Type: Desktop Mobo: BIOSTAR model: Z690GTA serial: <superuser required>
    UEFI: American Megatrends LLC. v: 5.24 date: 03/10/2022
CPU:
  Info: 12-core (8-mt/4-st) model: 12th Gen Intel Core i7-12700KF bits: 64
    type: MST AMCP cache: L2: 12 MiB
  Speed (MHz): avg: 1014 min/max: 800/10800:8500 cores: 1: 879 2: 876
    3: 801 4: 1041 5: 913 6: 1043 7: 1016 8: 1100 9: 1066 10: 1045 11: 962
    12: 1060 13: 964 14: 1022 15: 1125 16: 1059 17: 943 18: 1056 19: 1202
    20: 1109
Graphics:
  Device-1: NVIDIA GA104 [GeForce RTX 3070 Ti] driver: nvidia v: 510.60.02
  Display: server: X.Org v: 1.21.1.3 driver: X: loaded: nvidia
    unloaded: modesetting gpu: nvidia,nvidia-nvswitch
    resolution: 1920x1080~280Hz
  OpenGL: renderer: NVIDIA GeForce RTX 3070 Ti/PCIe/SSE2
    v: 4.6.0 NVIDIA 510.60.02
Audio:
  Device-1: Intel Alder Lake-S HD Audio driver: snd_hda_intel
  Device-2: NVIDIA GA104 High Definition Audio driver: snd_hda_intel
  Sound Server-1: ALSA v: k5.17.1-arch1-1 running: yes
  Sound Server-2: PipeWire v: 0.3.49 running: yes
Network:
  Device-1: Intel Wi-Fi 6 AX210/AX211/AX411 160MHz driver: iwlwifi
  IF: wlan0 state: up mac: 8c:1d:96:b6:7b:82
  Device-2: Realtek RTL8125 2.5GbE driver: r8169
  IF: enp5s0 state: down mac: f4:b5:20:44:1b:80
Bluetooth:
  Device-1: Intel AX210 Bluetooth type: USB driver: btusb
  Report: bt-adapter ID: hci0 state: up address: 8C:1D:96:B6:7B:86
Drives:
  Local Storage: total: 523.07 GiB used: 0 KiB (0.0%)
  ID-1: /dev/nvme0n1 vendor: Western Digital model: WDS500G1X0E-00AFY0
    size: 465.76 GiB
  ID-2: /dev/sda type: USB vendor: SanDisk model: USB 3.2Gen1
    size: 57.3 GiB
Partition:
  ID-1: / size: 10 GiB used: 168.7 MiB (1.6%) fs: overlay source: ERR-102
Swap:
  Alert: No swap data was found.
Sensors:
  System Temperatures: cpu: 31.0 C mobo: 27.8 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 429 Uptime: 1h 8m Memory: 62.65 GiB used: 3.58 GiB (5.7%)
  Shell: Bash inxi: 3.3.14

I’d probably pick one problem you want to solve and start there, for example working out why an update to the offline-installed Xfce fails to boot after an update.

You’re probably right, I’m ready for any and all mischief - but need help. In the end, however, after updating the offline installer XFCE environment I get the same error as with the online installer. No idea what is the best to start with, but in the end I would like to have KDE running. :grin:

I also had problems trying to install plasma desktop, i just do the offline install and then install the plasma desktop

Boot logs and calamares logs during the installs and boot logs after the install will help us diagnose the issue

Start with the minimal selection of packages that work, then add from there.

It’s important to get a working baseline before moving into further troubleshooting.

1 Like

Do a complete install and when Calamares finishes and says everything is done and complete BEFORE rebooting - This will show if something failed during the install even if it appears to have completed according to the GUI.

Please provide the install log

cat ~/endeavour-install.log | eos-sendlog
2 Likes

This command is supposed to run at the end of the install on terminal ? does it generate a link with the log or does it automatically send here on the forum ?

When everything is all done, one can open a terminal and run it. It generates a link for you to post here.

You are also not the OP, so if you do have an issue and are going to do this, please start another thread to not confuse folks. If you’re part of the tester team - it’ll be a regular thing for you. We use it a lot for testing. Please note - if you’re TESTING - to post in the proper areas. It does NOT belong in the general pool of help threads.

1 Like

OK thanks for all the replies in such a short time. Attached is the log of the last installation.

https://clbin.com/u8Pi8

No need for a link to your onedrive - just post up the link provided by the command. It links it to a pastebin and we can all click on it and see everything. :wink:

1 Like

I don’t think it’s a kde problem. It may be the newer kernel and or some other update. The online installer installs everything right up to date. The offline install has to be updated from where it’s packages currently are. It could be the nvidia driver since the online install is going to install the 515.48-2 driver version and the offline has the 510.60.02. This would be my first guess.

Hi and welcome to EnOS’ community @Exoomo!

Try the suggestion in the following link in your installed system: “online-ly” installed or offline-ly but updated to the latest and the greatest:

1 Like

Thanks @pebcak
I totally forgot about this. Hopefully it works.

Edit: I’m surprise this issue isn’t already fixed.

You won’t believe it but I can write the post from the plasma environment :crazy_face:. I have never been so happy to see a stupid login screen :sweat_smile:. What a difficult birth, but it’s alive - finally! Thank you all for the help :+1:.

Glad you got it resolved!
The credit is due to @dalto for posting the solution. I was just the delivery boy :wink: :blush:
Enjoy your EnOS’ Plasma!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.