Not able to boot after fresh install

I recently bought a new Asus laptop which have both an HDD and an SSD. It had windows already installed on the SSD, so I created a new partition on the SSD and installed EndeavourOS on it. Now when I booted the system from the grub screen, it shows this error.

I looked for the problem online and tried some suggested solutions. I have replaced the UUID=<UUDI> part with /dev/nvme0n1p5 in the / mount point entry in /etc/fstab, but I still got the same error. I also tried chrooting into the installation and running mkinitcpio -p linux but same result.

However I did observe a peculiar thing (atleast according to me). So my current partition scheme looks like this in Windows


But when I ran fdisk -l and blkid from the live usb, I only saw partitions on SSD (on /dev/nvme0n1 disk) and the usb itself (/dev/sda disk). I am neither able to see the HDD disk nor its partitions.

Also when it drops me to the emergency shell after boot fail, I tried running blkid from the rootfs prompt. But I only saw the usb drive. Both SSD and HDD were not visible. (Can be seen in the first picture).

I think there is some issue with these disks being not visible during the boot. Please help!

EDIT: My laptop is Asus Vivobook 15, Model Number X513EA-EJ532TS

I guess that means your initramfs is getting built without support for your disk controller.

Can you share the model number of your laptop? I would be curious to see that hardware specs on that.

Sure
It is Asus Vivobook 15, Model Number X513EA-EJ532TS

I have seen some other reports of having to add the vmd module to get tiger lake based laptops working. I am not sure if this is your issue or not but worth a shot.

Try booting off the live media and and use arch-chroot to access your installed system.

Then open up /etc/mkinitcpio.conf and add vmd to the MODULES line. Then run mkinitcpio -P.

3 Likes

Thank you!!
It totally worked!

1 Like