Nomachine, teamviewer, rustdesk problems

Hi, I love eos, but here’s this thing that I’m struggling with for days now.
Neither of the remote apps works on Endeavouros (nomachine, tw, rustdesk)
For first, I thought it is the firewall, but then I disabled firewall and still nope
I can connect to my Linux Mint machine out of the box, or Windows machines, but cannot connect to any of my Eos machines (got like 3 eos rigs because I love this distro <3 ).

All my machines are on the same local network ofcourse.

Nomachine (AUR): I can see all my eos on my local network, but when I try to connect, it says the target machine is not reachable.

Teamviewer (AUR): Doesn’t even connect.

Rustdesk: I installed every package from the AUR → I tried the compling version, then the bin version, then the appimage version (from github). When I connect via rustdesk, I see my desktop for 1sec, then it disconnects me without any warning messages…

I’m giving up hope.

I dont like VNC, because I’m not that smart to figure out how to properly configure it.

I’m looking for an out of the box it just works GUI solution (but not anydesk, I don’t like the business model of that company)

Any advice would be appreciated.

Rustdesk works here. I know that there free relay server is not of much use. I have installed my own RustDesk ID/Rendezvous server and RustDesk Relay server.

Teamviewer and Anydesk is the same business model, after some time all connections are short lived and you need a subscription.

Glad it works for you.

Didn’t know that, thanks for the info, I’m not gonna bother teamviewer to make it to work, doesn’t worth the time if it goes paid model after a time. :confused:

Then I guess I have no options.

The gnome remote desktop works really well for me. If you only want to access your devices it’s a good solution.
Rustdesk works for me to on gnome wayland. Your issue is really weird, because you can see your desktop for a second. I don’t think rustdesk needs extra ports. Did you try to start it from the terminal, maybe it shows some useful error messages. Are you on wayland? Never tried nomachine.

You can access the settings from here, you can even login from the GDM if you select the remote login tab

Sorry I totally forgot to mention that I’m on Plasma and tried both with Wayland and X11 without any luck. Maybe its Plasma then. I got an idea with RealVNC gonna give it a 2nd chance later today. :slight_smile:

I’m on Plasma and x11

I’m on Plasma with wayland.

Mostly using ssh for terminal stuff and waypipe for GUIs. When waypipe fail, steamlink is my alternative :yum:

I have seen this when using the free relay server. It’s most likely overworked and can’t handle all the connections, but I don’t really know…

Yepp, then it’s not plasma, that is my problem, I can’t troubleshoot. Started these programs from terminal, but doesn’t give back any usable info.

Yeah I’m totally fine with SSH, I use it daily, but I sometimes need a GUI for remote aswell. Waypipe seems a bit complex to me, but I’m gonna give a try to that also thanks

No idea, I tried this yesterday evening and today morning, and it is the same instant disconnect, if it truly the server overload, then I ditch rustdesk too. :smiley:

Running out of options, waypipe + realvnc today I’m gonna try these then, hopefully one of them will work. I just don’t get it, why is it that its only eos that these programs doesn’t work, but on Mint for example, Nomachine works like a dream out of the box? I love nomachine, becauce I can remotely mount local filesystems with a single click and vice-versa (locally mount remote filesystems), and that is what I mostly need, mounting filesystems temporary for a quick config share or stuff like that.

Its as easy as using ssh :grin: Simply install (AUR) on both side waypipe then:

waypipe ssh user@theserver your_app_name

You can also use ssh naming if you got somes of them configured. For example:

waypipe ssh nas firefox

1 Like

Gotcha it really seems simple :smiley: So If I get it right, I simply call:
waypipe ssh user@server dolphin for example, and it’s gonna open a Dolphin on my local machine from the remote’s POV? :open_mouth:

1 Like

Yes its exactly that :grin:

1 Like

Wow that rocks! Gonna give it a try now :smiley: fingers crossed :crossed_fingers:


waypipe ssh <filtered>@eos-lenovo.local dolphin
C1753: 90.549056 [src/client.c:208] WAYLAND_DISPLAY is not set, exiting
<filtered>@eos-lenovo.local's password: 
connect to /tmp/waypipe-client-WzcyhEq7.sock port -2 failed: Connection refused
S73102: 94.901139 [src/mainloop.c:1408] Channel hang up detected, no reconnection link, fatal
wl_display@1: error 3: waypipe internal error

Ok I give up. None of the remoting works for me :sob:

Are you on a Wayland session and did the target also have wayland installed ?

I’m currently on a X11 session, but the remote is on a wayland session. However I tried to switch my local session ofcourse to wayland, but after I installed this waypipe, and went into the wayland session, my screen is full black lol. I guess it screwed up my system xD

Edit, no it wasn’t waypipe, it was actually residual config files left from Nomachine

Hooo boy, this thing drives me nuts :smiley:

Ok so, nevermind, now waypipe works hooray, however I noticed it just opens up a local copy of a window :frowning: still need something, that I can control the mouse cursor remotely. Here’s the thing why: First, I got an nvidia card, that doesn’t run on wayland very well (we all know nvidia…), it only runs ok on X11, currently on wayland all my graphics are glitching and the cursor is backslashing as a type, weird experience I must say. The other stuff is: my parents need some help now and then, and I can’t see their machines this way, so if they need some help for example “ey son where should I click”, then I’m not able to click.

Simple task, yet struggling with a solution. My last hope is Realvnc. If that’s not working either, then I’m out of options :confused:

Erf, didn’t know we were talking about a nvidia system :sweat_smile:

I haven’t use x11 since 2019 but from what i remember vnc apps are supposed to work just fine.

TigerVNC was what i was using at the time with Remmina as client. I mostly use VNC in the context of virtualbox VMs this days so i can’t help you more :frowning:

1 Like

Good news everyone! I found my own solution, and I don’t know how in the hell could I ever forget these two great applications, which integrates with my Plasma, so I’m gonna leave this here, in case anyone else would ever need an out of the box experience remote solution:


IMPORTANT!!! After install, add port 5900 (tcp) to firewalld and you’re gucci

Thanks for all the inputs though

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.