No windows compatibility software works

Hey after having to reinstall Endeavour a couple of times because of some issues seemingly unrelated to the OS, I have finally landed on an instance that works well and is stable, i have downloaded Lutris and Steam(an enabled proton)
First I have tried to run my steam games already installed on my windows drive. which i wasnt expecting to work, then I installed a game locally on the linux drive, and it game me this error:unknown
I have reinstalled steam with pacman, and now launching games doesnt throw up an error, when i click play it says playing then goes back to play, and doesn’t launch.
I have tried installing the epic games launcher on Lutris which previously worked but now does the same thing as steam, i click play to launch the Epic launcher and it just doesn’t start, i don’t know what information I need to provide but I will answer any questions, thanks in advance!

Run steam in a terminal and see what output you get when launching the game.

1 Like

https://pastebin.com/vpsJWWMe - terminal output from start launching a game installed on the local drive
https://pastebin.com/H1KqNGJW - terminal output from start launching a game installed on the windows formatted drive(game was also installed in windows)
Hope this is what you need?

Looks like you’re trying to run your Steam library from a read-only NTFS drive.

pressure-vessel-wrap[56193]: E: openat(/mnt/085A6B495A6B331C/SteamLibrary/steamapps/common/SteamLinuxRuntime_soldier/soldier_platform_0.20210906.1/files/.ref): Read-only file system

This isn’t going to work - keep your Linux-native applications on a Linux-native filesystem.

2 Likes

I included that to be through, didn’t expect it to work, but still doesnt explain why the game installed on the same drive as the system itself, obviously a linux filesystem, doesn’t work either, or why lutris also fails to run anything
Also the drive being read only is odd but not the root of the issue, I also tried after I have given myself write permissions.
Also lutris/wine have an issue with finding freetype2 even thouhg i do have it installed

Both your logs show a read-only filesystem. It looks like the steam compatibility engine is installed to a read-only filesystem so even if the game is installed locally it can’t load the dependencies.

1 Like

Since you mentioned a Windows drive, I’m assuming that your system is a dual-boot, correct? Do you have fast boot enabled on Windows?

1 Like

It got automatically installed on that drive without asking so yes this might be the issue, giving myself write permissions to that drive doesn’t help but it being there might be the issue, i know steam in general has issues with running games from an ntfs drive, even on an instance where i got it working it wouldnt run games from it, will try to deal with that! thanks!

It is… kind of dual boot? i just have the systems installed on separate boot drives, fast boot should be disabled though I’ve had issues with it before so I will check

How are you giving yourself write permissions?

2 Likes

sudo mount -o remount, uid=1000,gid=1000,rw /dev/sda1
As someone said somewhere online, is there a better way? Sorry if it’s a stupid question/way to do it, but it does allow me to read and write to the disk just fine

How are you mounting it in the first place? Do you have an entry for it in /etc/fstab? If so, can we see it?

1 Like

The entries apart from the boot disk were added by the gnome disk utility since i didn’t feel comfortable messing with the file manually, the windows formatted drive is the 3rd entry

 

2 Likes

I meant better way to mount the drive and get rw permissions to it, i dont keep my linux apps there but most of my storage is on that drive

Something along these lines:

https://wiki.archlinux.org/title/NTFS-3G#Linux_compatible_permissions

You probably also want to include windows_names if you share the drive with Windows.

1 Like

So the issue definitely seems to stem from the windows drive, i can’t verify much rn since I’m really tired and the last time i tried configuring stuff late at night it didn’t end well, but does anyone know what the problem with lutris is?

From what i can tell it cannot start the epic games launcher because freetype2 is missing but it’s very clearly not, I have reinstalled it and can confirm it works because the steam launcher uses it

Still not working despite both proton and the game being installed onto the boot drive, any ideas why?
image

It is still failing to write to your NTFS drive:

pressure-vessel-wrap[71784]: E: Cannot create temporary directory "/mnt/085A6B495A6B331C/SteamLibrary/steamapps/common/SteamLinuxRuntime_soldier/var/tmp-NITXA1": No such file or directory
1 Like

I saw that but why is it even trying to? both proton and the game are installed on the local drive