No Wifi BCM43602

Just did a fresh install on my Dell XPS 15 and the Wifi isn’t working.

lspci reports that it’s a “Broadcom Inc. and subsidiaries BCM43602 802.11ac Wireless LAN SoC (rev 01)” and I have the following package installed

broadcom-wl-dkms which from reading the documentation out there should be enough.

Anything else I can try to do to get this working?

The new kernel 5.5.x has problems with some wifi cards.
Can you install and try the LTS kernel?

Just saw a thread on that and installed LTS to no avail :frowning:

I did a fresh install from a previous version which it was working - I just can’t remember what I did to get it working before…

Maybe blacklist some modules?

modprobe bcm43602

?

Make sure linux-headers are installed for the current kernel. If you install the lts kernel you would need linux-lts-headers.

Don’t forget to restart after installing and see if it works. It should as I am using it on Broadcom AC chip.

I’ve been having trouble with Broadcom 43142 for years, but one thing I’m sure of, when there are no problems with the kernel, it works great.

Now going to your problem with the bcm43602 I would do the following, sometimes it has worked for me.

sudo systemctl disable NetworkManager
sudo pacman -Rs broadcom-wl-dkms

reboot and then

sudo pacman -Syu broadcom-wl-dkms
sudo systemctl enable NetworkManager

reboot again and comment ?

Edit: Obviously all this with ethernet cable.

@Resiliencia
You could be right as it will rebuild the dkms and maybe fix the issue.

Apparently it was !!! :slight_smile:

Sorry for the delay in replying but it eventually worked but I am not sure what triggered it.

I tried following @Resiliencia but when I had the network manager disabled the USB Ethernet adaptor I had didn’t work.

Was super confusing :confused:

I did upgrade to 5.5.2 meanwhile so that might had something to do with it but even with the LTS kernel + headers I had no luck.

I flagged @Resiliencia as a solution but I am not sure what it was in the end…

1 Like

Of course, it happens that by disabling NetworkManager you are completely without a network administrator, and by restarting and re-enabling it, not always but sometimes it works the wifi is reactivated. Maybe because of the language barrier I didn’t know how to explain it well, using a translator, sorry for that.
But I’m glad it works now ! (it is very likely that the solution has been in the core upgrade to 5.5-2)

Have exact same WiFi module.

Decided to throw EOS on my old Macbook I use 2-3 times a year for travelling abroad. Probably a bad idea as you can imagine the backlog of updates everytime I take it out of storage and abroad.

  • ID: MacBook Pro12,1
  • Model: A1502 (EMC 2835)
  • Year: Early 2015
  • Wifi: Broadcom BCM43602
  • Wired: Broadcom BCM57762

Fresh EOS online install - To get the Wifi working from Arch wiki I made a /etc/modprobe.d/no_bmca.conf file and added line blacklist bmca. Then removed broadcom-wl package. So then brcmfmac open source driver will be used without conflict.

Rebooted and Wifi all working

2 Likes

This worked for me! Thank you so much for this solution!!