No WiFi after fresh install

Hello to you all,

I am an Endeavor OS first timer, with limited experience with Linux OS’s. I did search the Arch Linux wiki but was unable to resolve the issue.

After a fresh install, no WiFi options area available.

When I run the command ip link I only see this 1: lo: <LOOOPBACK, UP, LOWER_UP>

When I run lspci -k it does give me some info:

01:00.0 Ethernet controller: Marvell Technology Group Ltd. 88W8897 [AVASTAR] 802.11ac wireless
             Subsystem: Device 0008:045e
             Kernel driver in use: mwifiex_pcie
             Kernel modules: mwifiex_pcie

I am using a Microsoft Surface Pro

Note: I was able to use the tether options using a phone and USB cable and performed a system update, but the issue was not resolved.

Any help would be great; thanks!

1 Like

you need to install the linux-firmware-marvell package

sudo pacman -S linux-firmware-marvell

Welcome aboard! :smile:

Thanks for the report and solution! :+1:
This helps us provide better install experience for various devices, in this case Surface Pro.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.