No Wayland login option in GDM (GNOME)

I have no Wayland login option in GDM (GNOME). I found out that the folder .X11-unix is owned by gdm.
If I set root as owner of the .X11-unix ( thx @ringo ), I get back the Wayland login option and it seems that the login then works. But after a reboot the folder .X11-unix is again owned by gdm.

Can someone point me to solution for this problem?

Look into the file /etc/gdm/custom.conf and make sure this line:


looks as it should, that is, it look as above.

This is the content of /etc/gdm/custom.conf:

# GDM configuration storage

# Uncomment the line below to force the login screen to use Xorg




# Uncomment the line below to turn on debugging

Do you have an Nvidia card?

Please have a look at this:

Yes and I use the nouveau driver.

lspci -nnk | egrep -i --color 'vga|3d|2d' -A3

00:02.0 VGA compatible controller [0300]: Intel Corporation TigerLake-LP GT2 [Iris Xe Graphics] [8086:9a49] (rev 01)
	Subsystem: Dell Device [1028:0a22]
	Kernel driver in use: i915
	Kernel modules: i915
01:00.0 3D controller [0302]: NVIDIA Corporation TU117GLM [Quadro T500 Mobile] [10de:1fbb] (rev a1)
	Subsystem: Dell Device [1028:0a22]
	Kernel driver in use: nouveau
	Kernel modules: nouveau

Could you have a look at this part of the gdm troubleshooting on ArchWiki and see if it can be relevant to your issue?

It seems that the problem was wrong permissions of the root folder.

After running sudo chown root: / I have the Wayland login option in GDM.


Iā€™d be curious and concerned as to how that happened

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.