No Sounds at Boot?

This three your old thread is the only mention I could find of this problem (No Deepin sounds at login / logout - #7 by KewlToyZ) and it remains unsolved.

Does Endeavour have a unique tone on booting? Or is that something I have to enable? I use Budgie.

There is no place for ‘boot tone’ in system-settings. And I have ‘alert’ sounds set to none. (the ones where you have to pick between drip and dog etc).
Sound card is fine, speakers are fine, I get all sorts of sounds, play music. Sound settings in system-settings look completely normal. Sound functioning at 100% amplify.

The only sound I do not get is (what I imagine to be) a few unique boot up notes. It’s a nice flourish.
Could this be a systemctl service?

MODS: If Endeavour OS has no bootup sound/notes please delete post. Thanks for any troubleshooting.

I moved this to Desktop Environments, Budgie.

The answer is no. All Desktop Environments on EndeavourOS come “vanilla”, that is, without any custom themes or modifications. The only exception is the off-line install of Xfce, which is customised.

That means that if you want to add a custom sound at login, you need to do it yourself, EndeavourOS does not ship it (unless it is the default in the Desktop Environment).

I have no idea how this is done on Budgie, but I’m sure you can look it up yourself, or someone with more Budgie experience than me can tell you how to do it.

I think it’s DE-agnostic as they all have an autostart if you give it the right command.
But I like the stock setup in Endeavour and absence of boot sound is the smallest of small potatoes–I shall let it be.
Thanks for the confirmation, appreciate it.

It’s not DE-agnostic, as various DEs have different settings and different ways of achieving the same thing. I think all of the popular DEs have this option, and I’m sure you can figure it out, if you just look it up.

EndeavourOS does not come with pre-customised DEs, customisation is something every EndeavourOS user does him/herself.

sure, but the terminal output command you use will be distro-specific as far as terminology used if one created a startup command, plus folders/dirs/init or systemd etc. Ubu for instance: ( canberra-gtk-play --id="desktop-login" --description="GNOME Login").

It is true EOS does not provide a “unique tone on booting”, but Budgie does and all of the tools come with the DE when you install it. The way Budgie has historically implemented this feature is with Canberra and the “freedesktop” sound theme. On the stock EOS Budgie installation, both of these packages are installed by default.

In theory, all that needs to be done is to enable canberra-system-bootup.service and you are done. The fly in the ointment is the systemd unit provided for this service is not quite right:

Description=Play Bootup Sound

# A little optimization under the assumption that we are using the
# standard freedesktop theme

ExecStart=-/usr/bin/canberra-boot system-bootup

Also=canberra-system-shutdown.service canberra-system-shutdown-reboot.service

Perhaps it was ported over from another OS and never properly amended, I’m not sure, but system-bootup.oga is not a file provided by sound-theme-freedesktop on Arch.

You could amend the service to run a different file in /usr/share/sounds/freedesktop/stereo/, for example “service-login.oga” I think may be the very same sound, but even easier is to leave systemd out of it all together and just drop the command into a startup file in Budgie Desktop Settings > Autostart. Click the + button and choose “Add Command”.

Type this for your command:

/usr/bin/canberra-boot service-login

I can’t believe after so long on Solus, with that very ‘unique’ tone, the Strobl/Buddies crew would port a tone disabled to Endeavour…even Fedora Budgie defaults to a Fedora boot sound. I know of a ‘canberra’ oga but I don’t know the canberra oga but as long as they got it. Perhaps I will hear it soon!

whosever decision it was to ship/boot mute matters not. It’s interesting the intention (or mechanisms to get there) is there.

—ps—as long as I know where the folder is I can pipe in any oga I want so . Great commands. I will play my (your command) hunch and start with the systemctl enable and start from there.
thank you so much, Bluish Humility,

(now I get where Dalto was coming from: just because endeavour did not set it up that way did not mean budgie didn’t set it up that way…far out). I’m in my NEWB learning curve stage. I’ll be fixing your problems soon :crazy_face:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.