No sound on new laptop

I just finished a new EndeavourOS install on a new laptop, and I don’t seem to have any sound.

I’ve used a few different Linux distributions on my old laptop (an Asus Zenbook UX305F), first Ubuntu, then Antergos, and then EndeavourOS. But I wouldn’t considering myself too knowledgeable with Linux. I’d say I’m firmly in the “just enough to be dangerous” category.

I installed EndeavourOS on the new laptop, Dell XPS 13 (9310). I used the latest online installer (the Sept 2020 installer), and installed Gnome desktop. Everything generally went smoothly with the install, but in the sound settings, the only output option listed is “dummy output”. It also doesn’t seem to recognize the mic, and there aren’t any input options listed.

I’m not really sure where to start troubleshooting this, as all sound input and output worked fine on my old laptop, and I never really had to dig into it for configuration.

Thanks in advance for any help!

Thanks

1 Like

Welcome aboard!

Check hardware if it is Intel sound as it may require sof-firmware to be installed.

3 Likes

Are you able to post hardware output.

inxi -Fxxxza --no-host

It may help to check open alsamixer in your terminal and see if you’re muted at some low level.

2 Likes

thank you all for the very quick help.
I installed sof-firmware, rebooted, and that did the trick.

for reference, here’s the hardware output from:
inxi -Fxxxza --no-host


[jason@xps139310 ~]$ inxi -Fxxxza --no-host
System:
  Kernel: 5.9.12-arch1-1 x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-linux 
  root=UUID=578f62aa-8011-404c-b94f-3fb929a755ef rw quiet 
  resume=UUID=df5804e4-b024-4055-9a23-2f79cc82d8c1 loglevel=3 nowatchdog 
  Desktop: GNOME 3.38.2 tk: GTK 3.24.24 wm: gnome-shell dm: GDM 3.38.2 
  Distro: EndeavourOS 
Machine:
  Type: Laptop System: Dell product: XPS 13 9310 v: N/A serial: <filter> 
  Chassis: type: 10 serial: <filter> 
  Mobo: Dell model: 041XJ5 v: A00 serial: <filter> UEFI: Dell v: 1.0.3 
  date: 10/05/2020 
Battery:
  ID-1: BAT0 charge: 49.5 Wh condition: 51.0/51.0 Wh (100%) volts: 8.8/7.6 
  model: LGC-LGC6.5 DELL 2XXFW09 type: Li-poly serial: <filter> 
  status: Charging 
CPU:
  Info: Quad Core model: 11th Gen Intel Core i7-1165G7 bits: 64 type: MT MCP 
  arch: Tiger Lake family: 6 model-id: 8C (140) stepping: 1 microcode: 60 
  L2 cache: 12.0 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 44864 
  Speed: 1108 MHz min/max: 400/4700 MHz Core speeds (MHz): 1: 1108 2: 1164 
  3: 1101 4: 1013 5: 1166 6: 1194 7: 1171 8: 1153 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: Intel UHD Graphics vendor: Dell driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:9a49 
  Device-2: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo 
  bus ID: 3-6:3 chip ID: 0c45:672a 
  Display: x11 server: X.org 1.20.10 compositor: gnome-shell driver: intel 
  unloaded: fbdev,modesetting,vesa resolution: <missing: xdpyinfo> 
  Message: Unable to show advanced data. Required tool glxinfo missing. 
Audio:
  Device-1: Intel Tiger Lake-LP Smart Sound Audio vendor: Dell 
  driver: sof-audio-pci alternate: snd_hda_intel,snd_sof_pci bus ID: 00:1f.3 
  chip ID: 8086:a0c8 
  Sound Server: ALSA v: k5.9.12-arch1-1 
Network:
  Device-1: Intel Wi-Fi 6 AX201 vendor: Bigfoot Networks driver: iwlwifi 
  v: kernel port: 3000 bus ID: 00:14.3 chip ID: 8086:a0f0 
  IF: wlan0 state: up mac: <filter> 
Drives:
  Local Storage: total: 238.47 GiB used: 12.08 GiB (5.1%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/nvme0n1 vendor: Samsung model: PM991 NVMe 256GB 
  size: 238.47 GiB block size: physical: 512 B logical: 512 B 
  speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: 25307039 scheme: GPT 
Partition:
  ID-1: / raw size: 229.37 GiB size: 224.77 GiB (97.99%) 
  used: 12.08 GiB (5.4%) fs: ext4 dev: /dev/nvme0n1p2 
Swap:
  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 8.80 GiB used: 0 KiB (0.0%) 
  priority: -2 dev: /dev/nvme0n1p3 
Sensors:
  System Temperatures: cpu: 52.0 C mobo: N/A 
  Fan Speeds (RPM): cpu: 0 fan-2: 0 
Info:
  Processes: 260 Uptime: 2m wakeups: 574 Memory: 7.51 GiB 
  used: 2.29 GiB (30.5%) Init: systemd v: 247 Compilers: gcc: 10.2.0 
  Packages: pacman: 988 lib: 246 Shell: Bash v: 5.0.18 
  running in: gnome-terminal inxi: 3.1.09
2 Likes

Please put three ``` before and after the output. You can also use the </> tag button. I have fixed it for you… :hugs:

Welcome to the community :beers:

Glad it worked for you! Welcome to EndeavourOS.

In addition to the specific help on getting the sound running, thanks everyone for the warm welcome here. As I mentioned, I’ve been using EndeavourOS ever since Antergos came to an end. It’s been working so well, I never had a question to post here until today. I also have EndeavourOS running on an even older laptop that my daughter is using for school these days (remote learning in 5th grade). I think she’s the only one in her class not using a Chromebook.

I think that is just awesome! (Remote Learning)

Edit: I have also been here ever since Antergos ended. :slightly_smiling_face:

Glad it is fixed and welcome to the nut hutch!