No sound on Fresh Install with Intel i3 1005G1


I’ve been facing this issue for quite a while. I dropped EndeavourOS and tried a few other OSs and the issue pertains. Now I’ve come back and finally decided to make forum post instead of IRC.
I reinstalled it fresh today with 6.0.7 Kernel still can not see any output devices except the dummy output.
Audio doesn’t work with laptop speakers or earphones but works in bluetooth.
Alsa info

Please assist with this! Thanks a lot.

 inxi -A
  Device-1: Intel Ice Lake-LP Smart Sound Audio driver: snd_hda_intel
  Sound API: ALSA v: k6.0.7-arch1-1 running: yes
  Sound Server-1: PipeWire v: 0.3.59 running: yes

Welcome to the forum!

Try installing sof-firmware.

sudo pacman -S sof-firmware

Then reboot.

You could try the following kernel parameter in /etc/default/grub and then update grub with sudo grub-mkconfig -o /boot/grub/grub.cfg


Edit: Or you could also create the option in



snd-intel-dspcfg dsp_driver=1


Tried this. Have not seen any result. I have tried it before as well. Still showing no output devices.

Hello,what is the output of this line?

hwinfo | grep -i Sound | wc -l

for me 192 / Lenovo S145 81w8

It says only “157” nothing else.

I have a HyperX headphone. If I subtract those lines than 118 with me.
a working config

With Meld you can see the differences between our alsa-info files. /not found the reason/
In command window run


Check master volume if card is present

No it is not present. When I press F6. You can see intel HDA PCH But no card.

Hi, In the output of your
‘!!ALSA Information Script’ I see the same PipeWire ‘pseudo?’ card as in mine. From terminal my alsamixer shows this:
Sorry, I am not an expert.
If I boot an EOS live USB system (XFCE) the mixer works without any changes in config.

Same. But sound doesn’t work with live CD either. It works with Bluetooth though.