No sound in youtube videos (again)

Hi all,
I’m on kernel 5.9.1-arch1 and today I was checking a youtube video but there’s no sound all.
The sound icon is on, video moves correctly, but no sound.
However, I can hear perfect sound while playing any video on VLC or on SMPlayer.
I searched this forum and the Internet but couldn’t find anything.
Any help? Thanks!

Try the updates today (there are several for alsa) and they cured my similar difficulty earlier…

3 Likes

Thanks freebird54, but no updates for me since yesterday night. I’ll wait…

Hmmm- here’s the ones that fixed it for me (from /var/log/pacman.log)

[2020-10-21T18:27:08-0400] [ALPM] upgraded alsa-firmware (1.2.4-1 -> 1.2.4-2)
[2020-10-21T18:27:08-0400] [ALPM] upgraded alsa-topology-conf (1.2.4-1 -> 1.2.4-2)
[2020-10-21T18:27:08-0400] [ALPM] upgraded alsa-ucm-conf (1.2.4-1 -> 1.2.4-2)
[2020-10-21T18:27:08-0400] [ALPM] upgraded alsa-lib (1.2.4-2 -> 1.2.4-3)

Apparently it was alsa-ucm-conf that was the most likely fix - but not enough knowledge here to say…

1 Like

Yes, I got those updates yesterday, just checked, same version numbers. I guess my loss of sound started just after that.

Hmmm - I guess more versions are coming down the pike then! You could downgrade in the meantime, then retry in a week. (or back the upgrades out with ShiftTime)

ShiftTime script

Share your alias AND/OR function

2 Likes

Thanks freebird54
:+1:

1 Like

Ok. Solved.
By whatever magic, the audio volume in Applications, in the Status and Notifications panel (KDE), was turned off for Firefox when a video was running. I never touched that button before, so no idea why and how it was muted.
Anyway, I unmuted it as a video was playing, and all was fine.
Thanks freebird54 for the suggestions!

2 Likes

I can tell you it happened to me too and took me a while to figure it out. Just recently also on KDE.

1 Like

Update: this happened again today: no sound in Firefox, and again, I had to go to the sound setting to change it, although I did not touch anything since last time I fixed it. It seems as if something is resetting sound to mute.

Next time you have youtube open in Firefox check the Firefox icon and sometimes you’ll see the speaker in it and it is muted. Here is a picture of it in the task bar on KDE. Not sure if it’s just a KDE thing?

Edit: I think you can unmute it from there.

Thanks ricklinux.
Next time this happens I’ll double check the tab but I’m pretty sure I never clicked to mute it.
Cheers!