No sound from laptop internal speaker (mic and headphone are ok)

Hi after kernel upgrade my laptop internal speaker suddenly stop any sound. I tested mic and headphone and they are ok. Can someone help me?

What commands did you use? Any logs? Hardware info? Did you test in a live environment? Have you got other operating systems installed on the affected machine and if so, did you boot into those to test?

@dave Welcome BTW

this help you .

Hi, thaks for your help!

I upgrade system with pacman -Syu as ever.

Problem start with upgrade to kernel 5.10.11.arch1-1 from what I can figure out from my update history. Now I’ running on 5.10.14-arch1-1 (last kernel as I checked).

Pulseaudio is update at 14.2-2 version.

I installed sof-firmware without any luck.

I ereased user folder .config/pulse without any luck.

I disabled auto mute in alsamixer without any luck.

here is report from pactl list sinks

	Stato: SUSPENDED
	Nome: alsa_output.pci-0000_00_1b.0.analog-stereo
	Descrizione: Audio interno Stereo analogico
	Driver: module-alsa-card.c
	Specifica di campionamento: s16le ch 2 48000 Hz
	Mappa dei canali: front-left,front-right
	Modulo di appartenenza: 6
	Muto: no
	Volume: front-left: 27525 /  42% / -22,61 dB,   front-right: 27525 /  42% / -22,61 dB
	        bilanciamento 0,00
	Volume base: 65536 / 100% / 0,00 dB
	Monitor della sorgente: alsa_output.pci-0000_00_1b.0.analog-stereo.monitor
	Latenza: 0 usec, configurata 0 usec
	Flag: HARDWARE HW_MUTE_CTRL HW_VOLUME_CTRL DECIBEL_VOLUME LATENCY 
	Proprietà:
		alsa.resolution_bits = "16"
		device.api = "alsa"
		device.class = "sound"
		alsa.class = "generic"
		alsa.subclass = "generic-mix"
		alsa.name = "ALC269VC Analog"
		alsa.id = "ALC269VC Analog"
		alsa.subdevice = "0"
		alsa.subdevice_name = "subdevice #0"
		alsa.device = "0"
		alsa.card = "0"
		alsa.card_name = "HDA Intel PCH"
		alsa.long_card_name = "HDA Intel PCH at 0xf0610000 irq 32"
		alsa.driver_name = "snd_hda_intel"
		device.bus_path = "pci-0000:00:1b.0"
		sysfs.path = "/devices/pci0000:00/0000:00:1b.0/sound/card0"
		device.bus = "pci"
		device.vendor.id = "8086"
		device.vendor.name = "Intel Corporation"
		device.product.id = "1e20"
		device.product.name = "7 Series/C216 Chipset Family High Definition Audio Controller"
		device.form_factor = "internal"
		device.string = "front:0"
		device.buffering.buffer_size = "352800"
		device.buffering.fragment_size = "176400"
		device.access_mode = "mmap+timer"
		device.profile.name = "analog-stereo"
		device.profile.description = "Stereo analogico"
		device.description = "Audio interno Stereo analogico"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-pci"
	Porte:
		analog-output-speaker: Speakers (type: Altoparlante, priority: 10000, availability unknown)
		analog-output-headphones: Headphones (type: Cuffie analogiche, priority: 9900, not available)
	Porta attiva: analog-output-speaker
	Formati:
		pcm

This isn’t first time this problem came out, but in the past it was solved by itself after some kernel upgrade and a delete of user folder .pulse and ./config/pulse. Unfortunately not this time.

Hi thanks for your help.
Unfortunately I can’t find any solution there

Hi Dave. Feel free to hit me, but I have run into issues twice (once with sound) with EOS after important upgrades and spent hours trying to figure out why only then to reboot and find everything worked fine after the reboot.

Hi duple, I reboot several time my laptop but the problem persist.
I guess its a kernel bug but not sure about that.

Have you tried booting into the LTS kernel (use AKM in the welcome to install it and just select it in the GRUB menu when booting) to confirm that the kernel is the issue?

Hi, yes sir! I boot kernel-lts too but problem persist (as in the past and I bet that future kernel will solve as in the past).

Maybe downgrade pulseaudio and/or some setting in sound card?

I can’t undestand why this problem occur every 2-3 kernel upgrades.

If the problem is there in the LTS kernel as well, you might be better off downgrading to a kernel you know works. From there I would just hold off on kernel updates (or check them in a vm first, or be ready to downgrade) for awhile. There probably isn’t much going on with the very bleeding edge stuff that you would notice/miss anyway. Outside of that, we would need to get one of the kernel experts in here to help understand the differences in ones that work for you and ones that don’t and if there was anything you could do manually to a non-working one to make it work for you.

Thanks you all for your effort.

Today I try a live usb with the old endeavour os version I installed, and, even in that live os the internal speakers does not work (I know that speakes was working when I installed that os version months ago).

At this point I guess kernel update conflict with bios settings as touchpad too, randomly after start lost gesture setting and is slow untill I reboot.

Do you have any ideas how to solve?

How old is the machine and in what state? I’m beginning to suspect hardware failure might actually be an option…

Hi, my laptop (lenovo b590 with 3th gen intel cpu) is old (2013) but in mint condition and very good quality.

Yesterday, since I supposed bios conflict and start to investigate any errors with it, I tried to replace package intel-ucode with aur package intel-ucode-clear (cause my laptop has intel cpu) and all isssues was solved.

Thanks you all for help me.